What's up with these plants?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-04-2014, 10:51 PM   #1
mitko1994
Algae Grower
 
PTrader: (0/0%)
Join Date: Dec 2012
Location: Toronto
Posts: 7
Default What's up with these plants?

Hello Everyone,

I got these plants and they seem to be getting holes in their leaves as you will see in the pics below. I was wondering if they are caused by fish or deficiency. I have tetras,plecos,rainbows and some barbs.I recently started dosing with excel, flourish, and iron once a week. My tank is 90g, 24" tall and my light fixture is:Current USA Satellite 48-60". The Ozelot sword has been in the tank for about 2+ months, where as the other plant I got about 10 days ago

Here are the pics:
Click image for larger version

Name:	IMG_9946.jpg
Views:	28
Size:	48.9 KB
ID:	284010

Click image for larger version

Name:	IMG_9945.jpg
Views:	25
Size:	65.5 KB
ID:	284018

Click image for larger version

Name:	IMG_9944.jpg
Views:	26
Size:	43.2 KB
ID:	284026

Thanks

Last edited by mitko1994; 03-06-2014 at 09:00 PM.. Reason: typo
mitko1994 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:49 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012