Fuzz algae?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae


Reply
 
Thread Tools Display Modes
Old 12-07-2013, 11:59 PM   #1
WallEyes
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2013
Location: Wisconsin
Posts: 37
Default

Fuzz algae?


Hello,

I've been getting reoccurring outbreaks of a fuzzy algae on many of my plant leaves. Could this be a result of poor circulation within the tank? I have an over the back power filter that creates some circulation, but I was wondering if I should look into getting a powerhead, particularly the Marineland 600 model?

Maybe this powerhead with the combination of Amano Shrimp will help the situation? Any feedback/info would be greatly appreciated!

Thank you
WallEyes is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:29 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012