SafeTSorb and diatoms???
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-25-2013, 09:21 PM   #1
BriDroid
Planted Tank Obsessed
 
PTrader: (3/100%)
Join Date: Oct 2012
Location: Frisco, TX
Posts: 348
Default SafeTSorb and diatoms???

I have SafeTSorb in my tank and ever since day 1, I've had an issue with diatoms. Reading that diatoms LOVE silicates,, I thought I'll just wait it out. A couple of months later, and still have tons of diatoms.

Reading around the web, I found that some say clay soils leach silicates! Oh no, I have a clay based soil! I did a little more digging, and decided to try Seachem Phosguard. I picked some up today with a LFS I had credit with. It's in my filter now. Hopefully this will help absorb the extra silicates! Hopefully it will be enough and I won't be fighting an uphill battle.

If this doesn't help, I think I'm going to dump the SafeTSorb and try something else. After all, it's only $5 worth.

Has anyone else had these issues with SafeTSorb?
BriDroid is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:50 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012