Help: Melting Limnophila aquatica (ambulia)
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Plants


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-21-2013, 03:51 AM   #1
tithra
Planted Tank Obsessed
 
tithra's Avatar
 
PTrader: (14/100%)
Join Date: Dec 2012
Location: Vermont
Posts: 352
Default Help: Melting Limnophila aquatica (ambulia)

I have a newly setup (about a week old) 13.3 gallon tank.
*Lighting - 48watts t5ho
*Following EI dosing schedule
*co2 - 88g fluval kit (until I save up for something better)
*estimated co2 levels are 25 ppm (using ph/kh chart), drop checker is a happy green
*substrate - ADA aquasoil, about 2 inches deep
*no inhabitants currently (there is a betta that will call this tank home but she is in a different tank currently)
*zoo med 501 nano canister (cycled)
*pH 6.7, ammonia 0, nitrite 0, nitrate 5ppm

All plants are brand new, only about a week old. Everything seems to be adjusting ok so far except my limno. The bottom of the stems are completely melting away and bottom leaves are turning to grey mush.

I have had the same thing happen with this plant in a different tank and was unable to salvage it.

Tops still look nice and green, top half of stems still look good.

How do I save this plant before it completely melts away?? I read others say it grows easily and like a weed.... not sure what I am doing wrong. Any assistance is greatly appreciated
tithra is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:10 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012