Fugeray Wont Turn On
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Sponsors > Finnex / Schuber Wright


Reply
 
Thread Tools Display Modes
Old 06-27-2013, 12:07 AM   #1
IsNull
Algae Grower
 
PTrader: (1/100%)
Join Date: Aug 2012
Location: The Dirty South
Posts: 103
Default

Fugeray Wont Turn On


Ack! It flickered then went off. Won't turn back on and I've got $90 of new plants landing tomorrow!
IsNull is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-27-2013, 02:22 AM   #2
Cokers
Planted Tank Obsessed
 
Cokers's Avatar
 
PTrader: (3/100%)
Join Date: Aug 2011
Location: New York City
Posts: 304
Default

Did you try to perform some good old percussive maintenance?
Cokers is offline   Reply With Quote Quick reply to this message
Old 06-27-2013, 02:29 AM   #3
Lowe
Finnex
 
Lowe's Avatar
 
PTrader: (2/100%)
Join Date: Nov 2011
Location: Chicago
Posts: 655
Default

Hey, shoot customer_service@finnex.net an email!
Lowe is offline   Reply With Quote Quick reply to this message
Old 06-27-2013, 02:41 AM   #4
IsNull
Algae Grower
 
PTrader: (1/100%)
Join Date: Aug 2012
Location: The Dirty South
Posts: 103
Default

I used the contact us form on the web site, and got a copy of the email sent from the orders email address. I sent a copy of the issue to your customer service address along with a link to the purchase order.

Fingers crossed. I think it's the transformer. It's been getting real warm lately, but I thought that might just be the way it was designed.
IsNull is offline   Reply With Quote Quick reply to this message
Old 06-27-2013, 04:38 PM   #5
IsNull
Algae Grower
 
PTrader: (1/100%)
Join Date: Aug 2012
Location: The Dirty South
Posts: 103
Default

Got an email back from Customer Service. They said the unit was out of the 6 month warranty, but if I wanted to pay for shipping they would repair it for free this one time.

There's another thread talking about flickering issues with these lights and suggesting that there are quality control issues with the solder points.

I've been very pleased with the light itself. It seems very high quality. In fact I was considering selling it and stepping up to a Ray II. But it does give me pause if the product can't last a year.

Lowe can you address this any?
IsNull is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:09 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012