Stocked Tank Uncycled Filter and Algae, Plants not growing ....Please Help
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 05-21-2013, 04:59 AM   #1
Gareth:)
Newbie
 
PTrader: (0/0%)
Join Date: May 2013
Location: Australia, Brisbane
Posts: 1
Exclamation

Stocked Tank Uncycled Filter and Algae, Plants not growing ....Please Help


Hi, this is my first post and first fish tank, so I hope its in the right place and everything.

Iv had my tank for a couple months now and I've added a couple fish.
Everything was going well in the first couple of weeks I had 4 Neon Tetras cycling the tank, with ammonia around 0ppm. I got a bit impatient and wanted my plants to grow faster so I added more and more Flourish Comp.

Everything was growing well and then I got hair algae. Iv got rid of the hair algae, and then my fish got ich. I turned the heat up to 30 - 32C and used Blue Planet Rapid White Spot Remedy (Formaldehyde and Malachite Green) for two weeks. This was over a month ago.

But since the algae outbreak none of my plants are growing very well. They look deformed, bad colour and now they have black/brown algae on their laves. I also have green algae on rocks and glass, and brown on the gravel.

Also my filter must have got a air bubble in and stopped pumping water so I think my bacteria in the filter has died. Iv been doing 45% water changes for about 5 days, and the ammonia is around 0-0.25ppm, closer to 0.25 even after water change.

I must be doing something wrong with my plants and algae, but what is it?
Is there any way to remove ammonia faster until my tank cycles again?



TANK SPECIFICATIONS

60L tank with:

3x Neon Tetra
7x Glowlight Tetra
1x Bristlenose Catfish
1x Gold Ram

Plants are mostly stem plants but I have quite a few types and none are growing well

Aqua One Aquis Pro 550 External Filter
diy CO2
24W T5 Plant Light (Pink)
24W T5 Aqua (Blue(from ebay)) or 24W T5 10000K (White(from ebay))
9W Sterilizer (ebay)

Flourish Comp
Flourish Nitrogen (started 3-4 weeks ago(Started because Nitrate was at 0ppm))
Flourish Iron (started a week ago)
Flourish Trace (started a week ago)

ph around 6.8
ammonia 0.25 (with 45% water changes every day)
nitrite 0ppm
nitrate 10 - 20ppm


Please if you could help me I would be really grateful.
Gareth:) is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-21-2013, 11:20 AM   #2
Shawn123
Planted Member
 
PTrader: (1/100%)
Join Date: Jan 2013
Location: USA
Posts: 252
Default

I am not an expert but I would say that you're considered low light with those lights. For low light, I think you are ring heavy handed with your ferts, and just adding more and more fert won't make plants grow, you just have to be patient. How many hours are you running your lights for? Also, DIY co2 leads to inconsistent co2 levels which creates conditions algae thrive in. You may want to stop that and dose excel for a carbon source, and it also helps control algae. I don't know what you could do about the ammonia besides water changes or maybe adding one of the "Instant cycle" products would help.
Shawn123 is offline   Reply With Quote
Old 05-21-2013, 04:14 PM   #3
nameless?
Algae Grower
 
PTrader: (1/100%)
Join Date: May 2011
Location: Canada
Posts: 56
Default

Quote:
Originally Posted by Shawn123 View Post
I am not an expert but I would say that you're considered low light with those lights. For low light, I think you are ring heavy handed with your ferts, and just adding more and more fert won't make plants grow, you just have to be patient. How many hours are you running your lights for? Also, DIY co2 leads to inconsistent co2 levels which creates conditions algae thrive in. You may want to stop that and dose excel for a carbon source, and it also helps control algae. I don't know what you could do about the ammonia besides water changes or maybe adding one of the "Instant cycle" products would help.
48w of t5 over a 15 gallon (60 litre) tank is pretty high light imo.
nameless? is offline   Reply With Quote
Old 05-21-2013, 07:30 PM   #4
gSTiTcH
Planted Tank Enthusiast
 
gSTiTcH's Avatar
 
PTrader: (5/100%)
Join Date: Feb 2013
Location: Jacksonville, Florida
Posts: 838
Default

Back off on the ferts to start. Double check that you're not over feeding. Very easy to do.

Water parameters look good. I am not sure that DIY CO2 is going to work too well, given your lighting. That could be the source of your problem. Either cut lighting or increase CO2 (pressurized).

In the mean time, I would stick with the water change schedule and let things run their course. You can add chemicals, but you'll only be making things more fragile in the end. 0.25 is more ammonia than you would want to see, but it's not at critical mass right now.
gSTiTcH is offline   Reply With Quote
Old 05-22-2013, 12:44 AM   #5
Diana
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 7,714
Default

If the ammonia is .25 ppm even after a water change, then there is a problem. While a large % of it is in the less harmful ammonium form, even this is not benign. You definitely need to do something about it.

If you stop adding nitrate (fertilizer) the plants should increase their use of ammonia as a source of nitrate.

I would not add Excel or the generic form while you are still trying to grow nitrifying bacteria.

If you want to add more of the right species of bacteria look for Nitrospira on the label. All other 'bacteria in a bottle' products have the wrong species of bacteria.
Diana is online now   Reply With Quote
Reply

Tags
algae, fertalizer, filter help, plant help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:22 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012