Eheim 2217 leak
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 04-04-2013, 12:07 AM   #1
bpb
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Mar 2011
Location: College Station, TX
Posts: 628
Default

Eheim 2217 leak


So I have been using an eheim 2217 for about a year now. Bought it used. It's been a champ the whole time. Decided to take it apart for a quick cleaning which it needed. After putting it back together I've found a slow leak that wasn't there before. This happened with my eheim 2026 also. Every time I clean it, something would leak, I'd take it back apart, reassemble, leak stops.

I found the leak on the 2217 on the quick connectors for the input line right at the base. It's dripping about 1/4 cup of water a day but is a pain to clean up every day. It's dripping right where the two lines meet where you screw on the plastic tightening nut. I've disconnected it and reconnected it three times now thinking maybe I didn't tighten it enough. Aside from buying new quick connects, any ideas on how to stop the leak?
bpb is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-04-2013, 01:58 AM   #2
Sugardaddy1979
Sic em
 
Sugardaddy1979's Avatar
 
PTrader: (12/100%)
Join Date: Jan 2012
Location: Athens, GA
Posts: 639
Default

Is that o ring damaged? Make sure it is seated correctly and give it a lube of vaseline.
__________________
Sunsun Pimp Club Member #068
Sugardaddy1979 is offline   Reply With Quote Quick reply to this message
Old 04-04-2013, 03:04 AM   #3
xmas_one
Planted Tank Guru
 
xmas_one's Avatar
 
PTrader: (17/100%)
Join Date: Feb 2010
Location: Long Beach, CA
Posts: 3,256
Default

Quote:
Originally Posted by Sugardaddy1979 View Post
Is that o ring damaged? Make sure it is seated correctly and give it a lube of vaseline.
Yep, exactly this.
xmas_one is offline   Reply With Quote Quick reply to this message
Old 04-04-2013, 03:25 AM   #4
bpb
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Mar 2011
Location: College Station, TX
Posts: 628
Default

I'll take it apart and inspect with a flashlight in the morning. Hopefully I can get it to stop leaking. I'd hate to have to remove the quick connect.
bpb is offline   Reply With Quote Quick reply to this message
Old 04-09-2013, 01:40 AM   #5
KH2PO4
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Jul 2009
Location: N/A
Posts: 318
Default

Quote:
Originally Posted by bpb View Post
I've disconnected it and reconnected it three times now thinking maybe I didn't tighten it enough.
More likely than not that you overtightened it.
http://www.plantedtank.net/forums/sh...d.php?t=186770
KH2PO4 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:21 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012