No Planaria is not working
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Shrimp & Other Invertebrates


Reply
 
Thread Tools Display Modes
Old 03-20-2013, 12:32 AM   #1
Eightofnine
Algae Grower
 
PTrader: (1/100%)
Join Date: Nov 2011
Location: Tabor City, NC
Posts: 49
Default

No Planaria is not working


I have planaria in one of my spawn tanks. I have been trying to get rid of them for a long time and nothing seems to be working. No planaria stopped working. Hell, it's not even killing the snails in my 90 gallon any more. Any suggestions on what to use to kill the planaria?
Eightofnine is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-20-2013, 12:36 AM   #2
GeToChKn
Planted Tank Guru
 
GeToChKn's Avatar
 
PTrader: (1/100%)
Join Date: Apr 2011
Location: Hamilton, Ontario, Canada
Posts: 5,116
Default

Are you sure they are planaria. Other worms like detrius worms, etc, don't seem to be affected by it. I went through that before, trying to kill them and they weren't planaria. It wasn't until I went to my LFS and saw one of their tank infected that I realized what planaria were and that I didn't have them.
__________________
20g platy, , 2 x 10g shrimp, 3 x 20g shrimp, 7.5g shrimp and 1 great dane/mastiff puppy.

Sump Pimp #2

My Tanks and my shrimps
GeToChKn is offline   Reply With Quote
Old 03-20-2013, 12:39 AM   #3
Eightofnine
Algae Grower
 
PTrader: (1/100%)
Join Date: Nov 2011
Location: Tabor City, NC
Posts: 49
Default

Mine are slightly orange, about a centimeter max, some are smaller and have triangular heads.
Eightofnine is offline   Reply With Quote
Old 03-20-2013, 12:40 AM   #4
GeToChKn
Planted Tank Guru
 
GeToChKn's Avatar
 
PTrader: (1/100%)
Join Date: Apr 2011
Location: Hamilton, Ontario, Canada
Posts: 5,116
Default

Sounds like planaria. lol. If I remember, no-planaria is a "natural way" to kill them. You may have to resort to the dog-dewormer and go the "chemical bomb" way.
__________________
20g platy, , 2 x 10g shrimp, 3 x 20g shrimp, 7.5g shrimp and 1 great dane/mastiff puppy.

Sump Pimp #2

My Tanks and my shrimps
GeToChKn is offline   Reply With Quote
Old 03-20-2013, 12:52 AM   #5
Eightofnine
Algae Grower
 
PTrader: (1/100%)
Join Date: Nov 2011
Location: Tabor City, NC
Posts: 49
Default

I did try levamisole a while back with no fish in the tank. The tank has no plants. That didn't work. I may try fluebendazole. But I did just open a fresh bag of no planaria. My other bag was old. They do have a use before date on them. So, maybe it was just too old.
Eightofnine is offline   Reply With Quote
Old 03-20-2013, 11:55 PM   #6
Eightofnine
Algae Grower
 
PTrader: (1/100%)
Join Date: Nov 2011
Location: Tabor City, NC
Posts: 49
Default

Well, it's almost 24 hours since I added the no planaria. The snails are just loving it.
Eightofnine is offline   Reply With Quote
Old 03-21-2013, 12:00 AM   #7
h4n
Planted Tank Guru
 
PTrader: (713/100%)
Join Date: Jan 2006
Location: Charlton, Mass
Posts: 4,910
Default Re: No Planaria is not working

How much are you dosing? And what size tank?

I had good result with it in the past.

-Sent from my Samsung Note, a "Phablet"
h4n is offline   Reply With Quote
Old 03-21-2013, 12:23 AM   #8
Eightofnine
Algae Grower
 
PTrader: (1/100%)
Join Date: Nov 2011
Location: Tabor City, NC
Posts: 49
Default

I have a 90 gallon and I'm dosing for the 24 hour rate.
Eightofnine is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:08 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012