Knock off canister filter losing prime
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 03-01-2013, 11:52 PM   #1
Shangrila
Planted Member
 
PTrader: (2/100%)
Join Date: Oct 2012
Location: New York City
Posts: 256
Default

Knock off canister filter losing prime


I have a Chinese knock off Sun Sun canister filter with UV. Every couple of days it loses prime. It has no skimmer and all the intake hoses seem to be tight. I have to pump the prime button every other day to get it started again. Anyone else have this problem?
Shangrila is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-01-2013, 11:54 PM   #2
samee
Planted Tank Enthusiast
 
samee's Avatar
 
PTrader: (6/100%)
Join Date: Oct 2011
Location: Canada & US
Posts: 914
Default

Ive had this filter for maybe 2 years now, no problems yet, very quiet.
samee is online now   Reply With Quote
Old 03-02-2013, 12:27 AM   #3
sarahspins
Planted Tank Obsessed
 
PTrader: (2/100%)
Join Date: Sep 2012
Location: TX
Posts: 445
Default

Sounds like you probably have a leak at the seal.
sarahspins is offline   Reply With Quote
Old 03-02-2013, 12:14 PM   #4
pastert33
Algae Grower
 
PTrader: (5/100%)
Join Date: Jan 2013
Location: Georgia
Posts: 115
Default

I have a SunSun 302 and I am battling the same problem. Although mine is about 2 weeks old! Has me rethinking ever getting a canister filter again.
pastert33 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:58 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012