T5 problems
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 02-18-2013, 01:07 AM   #1
Ice Man
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2011
Location: USA
Posts: 15
Default

T5 problems


I just bought used GLO T5 high output 24 inch light. It came with no light bulbs. Previous owner claimed that it was a display light at local fish store and was never used. It looks brand new to me. I installed new T5 HO bulbs from zoo med. ligh fixture itself has no on/off switch. When plugged into power, it lights up only for 3-4 seconds and goes off. Is that sign of bad ballast?
Ice Man is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-18-2013, 01:18 AM   #2
mrkookm
Wannabe Guru
 
mrkookm's Avatar
 
PTrader: (94/100%)
Join Date: Apr 2007
Location: Delaware
Posts: 1,591
Default

Quote:
Originally Posted by Ice Man View Post
I just bought used GLO T5 high output 24 inch light. It came with no light bulbs. Previous owner claimed that it was a display light at local fish store and was never used. It looks brand new to me. I installed new T5 HO bulbs from zoo med. ligh fixture itself has no on/off switch. When plugged into power, it lights up only for 3-4 seconds and goes off. Is that sign of bad ballast?
It could be ballast, loose wiring, lamp not seated correctly or end corroded. I would check the last 3 before throwing in the towel.
__________________



The Junkie
mrkookm is offline   Reply With Quote Quick reply to this message
Old 02-18-2013, 01:46 AM   #3
Ice Man
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2011
Location: USA
Posts: 15
Default

Quote:
Originally Posted by mrkookm View Post
It could be ballast, loose wiring, lamp not seated correctly or end corroded. I would check the last 3 before throwing in the towel.
Well, there is no corrosion visible anywhere, light bulbs seams to be seated correctly. I don't know how to check for loose wire. Already called previous owner and will be returning it tomorrow.
Ice Man is offline   Reply With Quote Quick reply to this message
Old 02-18-2013, 04:45 AM   #4
Miles03
Algae Grower
 
Miles03's Avatar
 
PTrader: (1/100%)
Join Date: Feb 2012
Location: Las vegas, nevada
Posts: 38
Default Re: T5 problems

Pulled mine out of storage and one of the bulbs did the same thing...try checking the bulbs again and making sure they are turned all the way. If you think they are take them out and try it again...it worked for me hope it works for you its a good fixture.
Miles03 is offline   Reply With Quote Quick reply to this message
Old 02-18-2013, 06:42 AM   #5
PlantedTankLover
Planted Tank Obsessed
 
PlantedTankLover's Avatar
 
PTrader: (2/100%)
Join Date: Aug 2010
Location: NW Indiana
Posts: 361
Default

My Coralife t5 does the same thing when the bulbs are staring to go bad.
__________________
No, those are not my husbands tanks.

46 Bow Front Planted

Eheim 2217, 2-39wt T5 bulbs (6700k)
Onion plant, amazon sword, red lotus, Christmas moss, and crypt lutea. 7 pristella tetras, 7 cardinal tetras, 2 Otocinclus, 1 patty, and several cherry shrimp.

125 Cichlid

All Male Hap, Peocock, and Mumba Cichlids. Plus yoyo loach and zebra loach.
PlantedTankLover is offline   Reply With Quote Quick reply to this message
Old 02-18-2013, 06:45 PM   #6
Ice Man
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2011
Location: USA
Posts: 15
Default

Quote:
Originally Posted by Miles03 View Post
Pulled mine out of storage and one of the bulbs did the same thing...try checking the bulbs again and making sure they are turned all the way. If you think they are take them out and try it again...it worked for me hope it works for you its a good fixture.
I took that light fixture to my LFS. They replaced bulbs and exactly same think happened. I don't think it is bulbs or end caps problem.
I went back to return it. Guy who sold it to me was embarrassed about whole thing. He returned my money and told me I can keep the light.
Already ordered new ballast from bulk reef supply for $25. Hopefully it will work.
Ice Man is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:30 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012