Should I? Or should I not?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Substrate


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-05-2013, 08:27 PM   #19
sonoralinda
Algae Grower
 
sonoralinda's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2013
Location: Sonora, CA
Posts: 27
Default

Thurs. I used four bags of fluorite in my 75 gal. tank. The bag said not necessary to prewash but a quick rinse is up to you. Well I didn't want to rinse all the good minerals and stuff out of it so I put it straight in, planted heavy, (every 3" there's a plant) and took hours to fill it. I have emptied it and refilled it 4 times in the past 5 days. Every time it's filled, it's pretty clear then the next day it's like a foggy day where you can't see the house across the street. Today it's not quite as bad. I have an AC110 on it. My advice to anyone would be to rinse, rinse, rinse! I don't know how long this is going to last but it's disheartening! Newbie, sonoralinda
__________________
Sonora, CA

Last edited by sonoralinda; 02-05-2013 at 08:29 PM.. Reason: misselled name
sonoralinda is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:16 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012