parker h3l needle valve problem
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 01-31-2013, 11:50 AM   #1
bababooey
Algae Grower
 
bababooey's Avatar
 
PTrader: (21/100%)
Join Date: Nov 2011
Location: Atlanta, GA
Posts: 141
Default

parker h3l needle valve problem


I have a parker h3l needle valve that I may have broken somehow... -_-

http://www.plantedtank.net/forums/sh...d.php?t=194741
(This is a picture of the needle valve)

Last night, I was adjusting the valve and the top piece of the meter (smaller knob) came loose while I was turning it and came off the unit. Underneath, there is this metal ring with a notch and if i put the small knob back on, there is a small metal indention that fits snugly into the groove and will turn the metal ring.

Anyway, after the knob came off, I was able to put it back on and turn the meter like normal. It still clicks like normal and the larger meter spins as I turn the smaller knob. HOWEVER, its not adjusting the valve anymore. I tried to turn it all the way off and it was the same bps....then I tried to turn it all the way up and it was the same bps. The working pressure is set at 15 psi and I have a solenoid on a timer. Everything is still working right now except I just can't adjust anything...

So...did I just break the valve somehow or is there something I'm missing here?
bababooey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-31-2013, 01:51 PM   #2
exv152
Wannabe Guru
 
exv152's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2009
Location: Ontario, Canada
Posts: 1,205
Default

Did you keep the instruction manual that came with the valve? I think I might still have mine at home, and it basically goes over all the steps to install the knob etc. If not, I can check my manual and post back later tonight when I get home, but my first instinct is you may not have installed the knob correctly.
__________________
Eheim Pimp Club,# 496
25g 60-H
125g high tech
7g cube
33g iwagumi cube
75g low tech angelfish tank
exv152 is offline   Reply With Quote
Old 01-31-2013, 02:48 PM   #3
oldpunk78
ಠ_ಠ
 
oldpunk78's Avatar
 
PTrader: (105/100%)
Join Date: Nov 2008
Location: 96007
Posts: 5,226
Default

Did you tighten the set screws down after you put the knob back on? It came with a little Allen wrench that fits those set screws.
oldpunk78 is offline   Reply With Quote
Old 01-31-2013, 05:41 PM   #4
bababooey
Algae Grower
 
bababooey's Avatar
 
PTrader: (21/100%)
Join Date: Nov 2011
Location: Atlanta, GA
Posts: 141
Default

Quote:
Originally Posted by oldpunk78 View Post
Did you tighten the set screws down after you put the knob back on? It came with a little Allen wrench that fits those set screws.
AHHHHH, that fixed it. I guess the knob wasn't turning the valve because, duh, it was loose. BTW oldpunk, thanks again for helping me build my co2 regulator. I couldn't have done it without you!
bababooey is offline   Reply With Quote
Old 01-31-2013, 07:03 PM   #5
oldpunk78
ಠ_ಠ
 
oldpunk78's Avatar
 
PTrader: (105/100%)
Join Date: Nov 2008
Location: 96007
Posts: 5,226
Default

No problem. Glad to help
oldpunk78 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:40 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012