Heeeelp
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-31-2013, 12:48 AM   #1
lifeoffroad03
Newbie
 
PTrader: (0/0%)
Join Date: Jan 2013
Location: San Juan
Posts: 4
Default Heeeelp

So I have posted many times on a regular forum and I have tried everything recommended and still no luck.

So here's my setup:
55 gal with all normal levels except high nitrates as my tap water is high in nitrates. When I say that I am only reffering to the normal tests. Ammonia, Nitrate and nitrites.

Gravel substrate with one box of First Layer Lytrite and 10 Sea hem root tabs spread throughout

Liquid fert includes:
Flourish Excel
Flourish macro nutrients
Flourish potassium

I have 2 t5 bulbs one 6500 28 watt and one 58 watt and one accent light which is 18 inch forget specs.

My issue is the plants grow new sprouts but the plants themselves do not grow tall. When they do grow they get little holes. Not as many as they used to with the addition of potassium. Also they tend to quickly tun yellow and die.

My second issue is a bad case of algae mostly black beard. But when I clean the glass I get brown fuzz and green spots on the glass in like 2 days.

Anyway I don't want to patch anymore I want to do it right. Will dirt substrate resolve of my issues?

Thanks in advance.
lifeoffroad03 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:08 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012