Cloudy glass / mineral buildup / vinegar doesn't work
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-31-2013, 12:40 AM   #1
l8nite
Planted Tank Enthusiast
 
PTrader: (11/100%)
Join Date: Aug 2012
Location: Fremont, CA
Posts: 685
Default Cloudy glass / mineral buildup / vinegar doesn't work

My 110 tank has a glass brace in the center, was used when I got it. The brace is pretty cloudy with what looks like mineral buildup, and when I first got the tank I soaked and scrubbed with a razor it for a few days with no visible progress in clearing it up.

I've sort of lived with it to date but I notice the plants directly below the brace don't grow quite as much as the rest. Is there anything else I can try? I have some glass stovetop cleaner I might give a shot... Just need to figure out some way of preventing any from landing in my tank.
l8nite is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:30 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012