Noisey Filter
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 01-29-2013, 07:19 PM   #1
Dtitus1
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2013
Location: Northern Virginia
Posts: 39
Default

Noisey Filter


Just wanted to see what you guys thought, I have a 1 week old aquaclear 70 (a replacement for one of my other tanks), plugged in it out of the box and it rattled horribly, so I do what anyone would and lubed the impeller shaft and it's STILL noisy.

Think it's a wash or is there anything else you guys know of to try on it? It's not the lid cause I keep it off, I'm guessing it's an impeller issue but not sure what I can do.
Dtitus1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-29-2013, 07:21 PM   #2
pmcarbrey
Planted Tank Enthusiast
 
PTrader: (2/100%)
Join Date: Jan 2013
Location: kansas
Posts: 536
Default

Quote:
Originally Posted by Dtitus1 View Post
Just wanted to see what you guys thought, I have a 1 week old aquaclear 70 (a replacement for one of my other tanks), plugged in it out of the box and it rattled horribly, so I do what anyone would and lubed the impeller shaft and it's STILL noisy.

Think it's a wash?
Rattling usually means impeller problems, so if you lubed it and it still makes the rattling noise you may have a broken impeller shaft. Another possibility is a bad seal in the canister resulting in air getting in and causing rattling
pmcarbrey is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 07:25 PM   #3
Dtitus1
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2013
Location: Northern Virginia
Posts: 39
Default

What do you mean by canister? The U shaped tube? I am seeing air bubbles in my outflow so this might be it.
Dtitus1 is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 07:28 PM   #4
pmcarbrey
Planted Tank Enthusiast
 
PTrader: (2/100%)
Join Date: Jan 2013
Location: kansas
Posts: 536
Default

Quote:
Originally Posted by Dtitus1 View Post
What do you mean by canister? The U shaped tube? I am seeing air bubbles in my outflow so this might be it.
Sorry, wrong term for it, I meant somewhere in the impeller housing it might be getting in,
pmcarbrey is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 07:37 PM   #5
Dtitus1
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2013
Location: Northern Virginia
Posts: 39
Default

Hmm... not sure how to test for that I gotta think
Dtitus1 is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 07:44 PM   #6
drazend
Planted Member
 
drazend's Avatar
 
PTrader: (7/100%)
Join Date: Sep 2012
Location: Jackson, Tennessee
Posts: 288
Default

I second the impeller, I had one that no matter what I did rattled like crazy... as far as I could tell, nothing was broken and all was in order. no matter how much lube I put on the thing, it kept on rattling.

I even checked down inside where the impeller rests, to ensure nothing was sticking out or rubbing that would have caused the noise. I finally decided to take the impeller out of one of my other pumps and found it was silent..

Having said that, while I don't have an aquaclear, I would say, check where the impeller rests inside the filter and make sure there are no burrs or seems or anything that may have somehow become lodged in there.

I've also had one filter get air trapped in around the impeller that caused some noise issues. But, all of my filters were second hand... Good luck figuring it out, there's nothing more maddening than that constant repetitive rattle sound.

Last edited by drazend; 01-29-2013 at 07:49 PM.. Reason: I'm an english teacher's nightmare....
drazend is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 07:47 PM   #7
pmcarbrey
Planted Tank Enthusiast
 
PTrader: (2/100%)
Join Date: Jan 2013
Location: kansas
Posts: 536
Default

Yep, filter noises can be blamed on bad impellers (even a slight manufacturing error can unbalance an impeller and cause it to rattle) or air in the casing 99% of the time. Best of luck getting it to work
pmcarbrey is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 08:00 PM   #8
Dtitus1
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2013
Location: Northern Virginia
Posts: 39
Default

Thanks guys. I do have another one on hand because they accidentally shipped me two but I was just hoping to return it and get my money back (bad I know) guess I'll just have to open it.
Dtitus1 is offline   Reply With Quote Quick reply to this message
Old 03-03-2013, 12:44 PM   #9
stevencaller
Algae Grower
 
PTrader: (0/0%)
Join Date: Sep 2012
Location: UK
Posts: 71
Default

make sure you put the filter in water before trying it out. Vaseline will work in 90% of cases, other rattling filters are generally down to faulty parts
__________________
stevencaller is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:41 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012