Let's play "Guess the missing nutrient"!
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Fertilizers and Water Parameters


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-23-2013, 02:52 PM   #1
JeffHerr
Algae Grower
 
JeffHerr's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2010
Location: Valparaiso, IN
Posts: 101
Default Let's play "Guess the missing nutrient"!

I've got a 55gal Carbon-supplemented tank, fully cycled. New to EI, about 3 weeks. Many new plants added at that time.
Dosing:
1/4 tsp KNO3 x 3
1/8 tsp MKP x 3
1/8 tsp K2SO4 x 3
1/4 CSM+B x 3 (alternate with macros)
10mL Excel daily
1/8 iron (DPTA) on non-CSM days

My hygro old leaves are falling away due to the new tank transfer, which I expected, but they're curling. Potassium?
Click image for larger version

Name:	ImageUploadedByTapatalk1358956198.946505.jpg
Views:	124
Size:	63.4 KB
ID:	72090

My (sword?) has dark veins and a dark almost-texture to them.
Click image for larger version

Name:	ImageUploadedByTapatalk1358956250.019935.jpg
Views:	79
Size:	85.4 KB
ID:	72098

My stem plant (what is it?) keeps losing tips, mostly on old leaves but still strong presence on new.
Click image for larger version

Name:	ImageUploadedByTapatalk1358956279.809523.jpg
Views:	79
Size:	76.6 KB
ID:	72106

Okay, what're your guesses?

Thanks! Jeff
JeffHerr is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:32 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012