Ista Max Mix Co2 Reactor
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 01-02-2013, 03:24 PM   #1
tylergvolk
Wannabe Guru
 
PTrader: (12/100%)
Join Date: Jun 2012
Location: Minneapolis, MN
Posts: 1,059
Default

Ista Max Mix Co2 Reactor


I just hooked up my Ista Max Mix Co2 Reactor (Medium) to my Eheim 2213 canister yesterday. Everything seems to be working well. The noise level is low, and the co2 seems to be dissolving 100% (for the most part).

I've looked up videos on youtube regarding the Ista Max Mix Co2 Reactor and it the videos show the top 2 propellers moving very fast. Mine are not; in fact, the top one doesn't move at all and the 2nd one from the top moves very slowly.

Should I be concerned?
tylergvolk is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-02-2013, 03:35 PM   #2
tylergvolk
Wannabe Guru
 
PTrader: (12/100%)
Join Date: Jun 2012
Location: Minneapolis, MN
Posts: 1,059
Default

After a quick search here on the forums, I found the answer to my problem.

"Once I fired up the system, driven by an XP1, I found out that the top impeller would not spin correctly. I could have let it be, I believe the CO2 still would have been integrated into the system (physics are physics), but I tore it down and started the tinkering. Inside the body there was a small molding sprue issue that left a bump on the top of the unit which was hanging up the impeller. The other units also have molding marks, which will require some cleaning up to function smoothly in my opinion. I took a wooden dowel and taped some 150 grit sand paper on to the end and sanded it down. I cleared the obstruction with sanding and reassembled. The top impeller then spun smoothly."

http://www.plantedtank.net/forums/sh...ta+co2+reactor
tylergvolk is online now   Reply With Quote
Old 01-02-2013, 03:45 PM   #3
zico_aqua
Planted Member
 
zico_aqua's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2012
Location: India
Posts: 175
Default

as long as the diffusion is 100% that should be least of your concern..
__________________
Abhradip Choudhuri

Good judgement comes from experience, and experience comes from bad judgement.


Few of my works
zico_aqua is online now   Reply With Quote
Old 01-02-2013, 04:27 PM   #4
Kado
Planted Member
 
PTrader: (0/0%)
Join Date: Oct 2012
Location: Japan
Posts: 181
Default

Yup top 2 should spin, but bottom one doesn't. I don't get 100% diffusion with mine, but what doesn't get diffused comes out of the spray bar really fine. I'm just happy it works with my diy co2.
Kado is offline   Reply With Quote
Old 01-02-2013, 05:03 PM   #5
tylergvolk
Wannabe Guru
 
PTrader: (12/100%)
Join Date: Jun 2012
Location: Minneapolis, MN
Posts: 1,059
Default

Quote:
Originally Posted by zico_aqua View Post
as long as the diffusion is 100% that should be least of your concern..
Yea, it hasn't even been setup for 1 day yet, but I do get 100% dissolving "for the most part" there are times when it starts to spit out tiny bubbles.
tylergvolk is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:42 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012