API Algaefix...
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-07-2012, 07:08 PM   #17
talontsiawd
Planted Tank Guru
 
talontsiawd's Avatar
 
PTrader: (1/100%)
Join Date: Oct 2008
Location: Concord, CA
Posts: 4,223
Send a message via AIM to talontsiawd
Default

I just started using algae fix for the first time as I have this string algae that is seems to love the same conditions as the plants so it only struggles when my plants struggle. So far it isn't working well for this type of algae, but did get rid of the small amount I had on the glass and driftwood so I know it's doing something.

However, to my surprise, my plants didn't even flinch. I knew it was plant safe but I thought it would have some effect. They are just growing as they used to, still getting great growth and color, so not seeing any side effects there. Snails are dying but that's fine by me. Fish is not acting/looking any different.

Just saying, I had my concerns as well and now I am confident that this stuff is safe for plants and fish.
talontsiawd is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:22 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012