Question about setting up Co2 regulator - Page 3
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 11-10-2012, 06:48 PM   #31
TheKribKeeper
Algae Grower
 
TheKribKeeper's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2012
Location: California
Posts: 130
Default

Could be a bad check valve some need high psi to open referred to as cracking pressure. Or it is stuck closed. But you did right by trying a cheap plastic one now you know the problem lies with the check valve or the diffuser.
TheKribKeeper is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2012, 08:23 PM   #32
trixylarue
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Default

Still no gas in the tank. All it seemed to be doing it sucking water back up through the tube. I am trying another cheap diffuser just to see if that is the problem...waiting for pressure to build....sooo wanting to see bubbles in the tank!
trixylarue is offline   Reply With Quote
Old 11-10-2012, 08:34 PM   #33
Darkblade48
Moderator
 
Darkblade48's Avatar
 
PTrader: (3/100%)
Join Date: Jan 2008
Location: Toronto
Posts: 9,111
Default

If you want to eliminate the possibility that it is a faulty diffuser, simply take the diffuser out and have the airline tubing bubble directly into the aquarium.
__________________
Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline   Reply With Quote
Old 11-10-2012, 09:09 PM   #34
trixylarue
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Default

I tried testing with just the tubing (see previous page) and the tubing does bubble in the tank (very slowly) - but I still can't get this to work with ANY diffuser. #2 not working - it's been 45 minutes. I have the pressure at 30.
trixylarue is offline   Reply With Quote
Old 11-10-2012, 11:12 PM   #35
Darkblade48
Moderator
 
Darkblade48's Avatar
 
PTrader: (3/100%)
Join Date: Jan 2008
Location: Toronto
Posts: 9,111
Default

Quote:
Originally Posted by trixylarue View Post
I tried testing with just the tubing (see previous page) and the tubing does bubble in the tank (very slowly) - but I still can't get this to work with ANY diffuser. #2 not working - it's been 45 minutes. I have the pressure at 30.
My apologies, I only skimmed through the last page.

If your regulator is set at 30 PSI delivery pressure (and assuming your needle valve is open wide), and your tubing is only bubbling very slowly into the aquarium, I would look for a leak. Even at 10 PSI, my tubing will bubble very quickly.
__________________
Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline   Reply With Quote
Old 11-10-2012, 11:55 PM   #36
trixylarue
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Default

I received an e-mail from Green Leaf and they said the same thing. I shut it all down and I will take it all apart and start over again tomorrow to see if that fixes it. Thanks for your help!

Last edited by trixylarue; 11-11-2012 at 12:45 AM.. Reason: spell correct
trixylarue is offline   Reply With Quote
Old 11-14-2012, 07:59 PM   #37
trixylarue
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Default

Here is an update on my CO2 woes: I still cannot figure out how to make this thing work. I used dish soap and found a leak at the top of the bubble counter. I took off the top and screwed it back on and it seems to have fixed it. I still have the pressure at 30, there are bubbles coming out of the tube at about 1 per second (the bubble counter is currently set at 3 per second until I get this thing working). but still nothing will come out of a diffuser and I tried two different types. I am completely clueless.
trixylarue is offline   Reply With Quote
Old 11-14-2012, 09:32 PM   #38
oldpunk78
ಠ_ಠ
 
oldpunk78's Avatar
 
PTrader: (105/100%)
Join Date: Nov 2008
Location: 96007
Posts: 5,230
Default

Can you take a photo of the low pressure gauge?
oldpunk78 is online now   Reply With Quote
Old 11-14-2012, 10:24 PM   #39
trixylarue
Algae Grower
 
PTrader: (0/0%)
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Default

Well I finally got it working. It seems there was a leak in the check valve. I stuck in under water and it was bubbling. I took it off and now everything is working properly. Now I just got to buy a new one and I should be set. Thanks for your help everyone!
trixylarue is offline   Reply With Quote
Old 11-15-2012, 12:08 AM   #40
Darkblade48
Moderator
 
Darkblade48's Avatar
 
PTrader: (3/100%)
Join Date: Jan 2008
Location: Toronto
Posts: 9,111
Default

Glad we could be of assistance
__________________
Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:12 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012