New tank has cloudy water? not enough filtration?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-22-2012, 05:00 PM   #1
johnnysk8s
Newbie
 
PTrader: (0/0%)
Join Date: Oct 2011
Location: ocean springs ms
Posts: 1
Default New tank has cloudy water? not enough filtration?

I have a 20 gal tall that I recently made into a planted tank. It has been a month now and the water is still very cloudy. I had some initial trouble with what I think was green spot algae, but I have lowered the photo period to 8 hours, and the algae situation seems to be getting better. My concern is the cloudy water. I have changed out the filter 3 times in two weeks. It looks like thousands of tiny bubbles? I am wondering if my hang of the back filter that came with the tank is the issue? Thanks for any help I may get. Here are my specs

20 gal tall
T5 x4 daylight bulbs
Regular off the back filter that came with tank
DIY CO2 with 1 bubble in tank/5 sec.
Flourite substrate
Flourish Micronutrients
Leaf Zone Potash
72 degrees
photo period 8 hours
ph 7

2 platies4 neon tetras
2 cory cats
2 black skirt tetra

4 amazon swords ( I know that is too many)
1 java fern
3 money warts

4 neon tetras
2 cory cats
2 black skirt tetra

4 amazon swords ( I know that is too many)
1 java fern
3 money warts
johnnysk8s is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:10 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012