Clean plants from cladophora with heavy circulation?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae


Reply
 
Thread Tools Display Modes
Old 11-21-2011, 01:50 AM   #1
Raven
Newbie
 
PTrader: (0/0%)
Join Date: Apr 2006
Location: Sweden
Posts: 2
Default

Clean plants from cladophora with heavy circulation?


A couple of months ago i put 3 plants in a container with lots of circulation, more then 50x the volume and a fineparticlelfilter, then i planted the plants in a bucket with some gravel and a miniature filter and fertilizers.

The cladophora is nowhere to be seen today in the bucket and all 3 plants have grown new leafs, would you say the plants are clean from cladophora or?

Regards
Raven
Raven is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-22-2011, 10:46 PM   #2
sketch804
Wannabe Guru
 
sketch804's Avatar
 
PTrader: (44/100%)
Join Date: Mar 2011
Location: Richmond, Virginia
Posts: 1,229
Default

yes i believe they are, i have had to do the same thing in one of my tanks and just pointed the powerhead i had at them and they seems to melt right off. But that still doesn't fix your underlined cause of why it sprung up anyway..i have the same problem i am dealing with in my tank except it is trying to take over my whole tank, and its been running for years now ugh..but i find that Nitrates are the problem when dealing with BGA. lots of water changes and reduce feeding or the stock of fish in your tank if possible. i have done the same in my tank but still its killing me..so just do a little research and keep up on the tank changes and you should be fine..and yes those plants should be clean now since they were taken out of the environment.

-Sketch804
sketch804 is offline   Reply With Quote Quick reply to this message
Old 11-22-2011, 11:05 PM   #3
Raven
Newbie
 
PTrader: (0/0%)
Join Date: Apr 2006
Location: Sweden
Posts: 2
Default

Quote:
Originally Posted by sketch804 View Post
But that still doesn't fix your underlined cause of why it sprung up anyway.
It came from infected plants, i know exactly which plants, where they come from and when.
Raven is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:15 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012