New to all of this...and I think I'm already doing it wrong. - Page 2
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 08-12-2010, 03:43 AM   #16
Eden Marel
Planted Tank Guru
 
Eden Marel's Avatar
 
PTrader: (38/100%)
Join Date: Jan 2010
Location: Longmont, CO
Posts: 3,379
Default

Quote:
Originally Posted by mysticseaport View Post
I just did a Google search of the scientific names of the ferns, and neither of them are even aquatic. One actually is commonly found in woodland forests. This is ridiculous. I am merely an ill informed consumer. Damn you for thriving off of my ignorance, TopFin. How is it possible that they can get away with selling these as plants "for aquariums"?

I know what you mean, I thought aquarium plants meant aquarium plants. RETURN THEM. I bought some when I began my tank, and noticed things happening. I dug through the smelly kitchen trashcan for the tubs and shoved the plants back in and returned them. I did rinse the tubes though... so they weren't tooooo stinky.
__________________
Eden Marel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Tags
i'm dying, needed, newbie, oh dear, substrate

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:00 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012