Rena Filstar XP3 - larger o-rings?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-15-2010, 03:48 PM   #1
jawn_nm
Newbie
 
PTrader: (0/0%)
Join Date: Feb 2010
Location: Albuquerque, NM
Posts: 1
Default Rena Filstar XP3 - larger o-rings?

I got a Rena Filstar XP3 thrown in with my 75G tank that I'm setting up now. I'm planning on pretty heavily planted with some fish (not a ton, but maybe ~30 inches?). I'm using a Hydor in-line heater and a Rex reactor for CO2. The filter ran fine for about a week before I added the reactor and heater, but now it leaks out of the power cord hole after about an hour. I replaced the o-rings on the quick disconnect, and re-greased them (and the rings inside the disconnect too). It ran for about 5 hours and then started leaking. Anyone try using larger o-rings to stop the leaking? I'm ready to just bag this filter and buy another one (Eheim 2217?) but I thought I'd give the Rena one more chance!
jawn_nm is offline   Reply With Quote
 

Tags
leak, power, rena, ring, xp3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:50 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012