Algae - Help me
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae


Reply
 
Thread Tools Display Modes
Old 02-21-2013, 02:05 PM   #1
desitetra
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2013
Location: Chennai, India
Posts: 19
Default Algae - Help me

Its been 3 weeks since I setup this tank. But Algae is just growing everywhere... on the driftwood, plants, tank and the substrate. Not sure on what type of algae it is and how to control it. Its all over my x-mas moss and its frustrating that I need to deal with this within 3 weeks of starting this hobby. Please help.

Tank Size: 90 x 36 x 50 cm
Light: 4x39w T5 HO. 8 to 9 hours daily.
CO2 : Pressurized. 1 bubble / second. 8 hours (same as light but 30 mins before)
Fertilizer: Adding 25 ml of JBL Ferropol on alternate days.
Attached Thumbnails
Click image for larger version

Name:	Algae1.jpg
Views:	22
Size:	404.5 KB
ID:	91418  

Click image for larger version

Name:	Algae2.jpg
Views:	19
Size:	341.2 KB
ID:	91426  

Click image for larger version

Name:	Algae3.jpg
Views:	18
Size:	46.3 KB
ID:	91434  

Click image for larger version

Name:	Algae4.jpg
Views:	17
Size:	466.2 KB
ID:	91458  

Click image for larger version

Name:	Algae5.jpg
Views:	17
Size:	327.1 KB
ID:	91466  

desitetra is offline   Reply With Quote
Old 02-21-2013, 04:32 PM   #2
puopg
Planted Tank Enthusiast
 
PTrader: (13/100%)
Join Date: Sep 2012
Location: Sacramento, CA
Posts: 757
Default

Staghorn and diatoms. Diatoms are very common with new setups. They go away on their own. Staghorn can be removed by hand but typically appear in low flow areas. You definitely have too much light. ~160W for a 42 gallon tank is overkill. Obviously, would rather look at PAR but chances are, you got too much light. CO2 at 1 bps is pretty low, see how far you can push it but do so slowly. Also do like 3-4 WC weekly for the next 3 weeks.
puopg is offline   Reply With Quote
Old 02-25-2013, 03:26 PM   #3
desitetra
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2013
Location: Chennai, India
Posts: 19
Default

Also I just found out that I'm doing a big mistake.

Actually I'm using 100% RO water. I didn't mix any tap water to it. Only fertilizer that I was using is Ferropol which may not be enough I believe. I already lost 6 neons.

Any help how to restore sanity would be highly appreciated.

1. Should I mix 50% tap water to the RO water for next water change?

2. What the fertilizers that I should add apart from JBL Ferropol?

Thanks.
desitetra is offline   Reply With Quote
Old 02-25-2013, 03:54 PM   #4
Dx3Bash
Planted Tank Obsessed
 
Dx3Bash's Avatar
 
PTrader: (7/100%)
Join Date: Jan 2013
Location: Minnesota
Posts: 450
Default

You can mix tap woth RO to remineralize the RO water. How much? Depends on the tap water ph, gh, kh and what water parameters you want for your aquarium. You can also remineralize with baking soda and something like GLA GH booster.

You also have too much light. Try cutting to two bulbs with the others for a quick noon burst for an hour or so, but no more. At 1 bps is your drop checker lime green? If not, maybe increase your CO2. I have a 55 gallon and run 4-5 bps. I also only have a 3 bulb fixture. So i run less light and more CO2, and no algae. If your tank is still really bad, maybe it would be easier to empty it and clean your plants with an H2O2 dip. You can then add proper water with clean filters and a better understanding of your initial mistake. Another thought is the "One Two Punch" Algae treatment discussed and explained on this forum under the Algae thread. You first add H2O2 to entire tank folled by Seachem Excel. I havent tried but it appears to work great for entire tank treatments. Can be hard on some fish and inverts though. Also would recommend dosing Seachem Excel daily. Excel is proven to help control most types of algae.

Not familiar with your ferts. I use dry ferts purchased from GLA. Macros/micros dosed every other day, alternate days. EI Dosing.

Finally, are you doing regular water changes? Good tank hygein is always helpful. I change 50% weekly, sometimes even more. This is required for EI dosing, but also helpful regardless.
__________________
Dx3Bash is offline   Reply With Quote
Old 02-25-2013, 06:12 PM   #5
Bubba_Shrimp
Planted Tank Obsessed
 
Bubba_Shrimp's Avatar
 
PTrader: (26/100%)
Join Date: Jun 2009
Location: Atlanta, GA
Posts: 426
Default

Normal dosing of Excel will help. Increase CO2 so it won't get back. Read this post: http://www.plantedtank.net/forums/sh...ad.php?t=59628
Bubba_Shrimp is offline   Reply With Quote
Old 02-26-2013, 04:06 PM   #6
desitetra
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2013
Location: Chennai, India
Posts: 19
Default

Thanks puopg, Dx3Bash & Bubba_Shrimp.
desitetra is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:26 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012