The Planted Tank Forum - View Single Post - The Dragon's Lair - New pics 10/24/10
View Single Post
Old 01-13-2010, 03:42 AM   #32
cah925
Fear the Swamp!
 
cah925's Avatar
 
PTrader: (173/100%)
Join Date: May 2007
Location: Riverview, FL
Posts: 2,504
Default

I raised the light several inches to try and clear some BBA several weeks ago. The BBA went away, but several plants started to die. I lost most of my Blyxa on the left side and almost lost my Limno sp 'Mini'. I put the legs back on the light and repositioned it on top of the tank last week. For now, I'm only using 2 of the bulbs (instead of 4) to see if I can keep the BBA from coming back. I've also been having a major issue with cloudy water for some reason. I'm not sure if the eels are digging around stirring up dust from the substrate or if there is some other underlying issue. I have also been dealing with green dust algae for about a month. I stuck to a strict dosing regimen and water change schedule. I finally stopped scraping everything and just let it go to see if it would resolve on its own. Last week I added 8 otos and they have been busy. Tonight was the first night I didn't see any dust algae on the glass. Not sure which of the many things I have tried helped, but I'm glad to see it finally disappearing. Now if I could just get rid of the cloudy water everything would be great.
Here's a few pics I took earlier.
FTS


Top shelf above the cave-crypts are filling in nicely, many are sending out runners with new plants popping up all over the place.
cah925 is offline   Reply With Quote