The Planted Tank Forum - View Single Post - Using purigen in a sponge filter
View Single Post
Old 11-07-2013, 03:43 AM   #20
xmas_one
Planted Tank Guru
 
PTrader: (17/100%)
Join Date: Feb 2010
Location: Long Beach, CA
Posts: 3,245
Default

Quote:
Originally Posted by Diana View Post
Probably would.

I would approach the problem this way:

Step 1: Remove nitrates from the tap water, or use a water that has none. This is a small tank, it will not blow the budget to buy RO or distilled water for it. Use tap water ONLY if it is proven that the plants are capable of handling the nitrate load.

Step 2: Redo the tank, removing the substrate (and its overload of Osmocote).

By removing two of the three sources of NO3 you are left with the protein in the food as the main source, and every fish/shrimp keeper deals with that. A good assortment of plants ought to be able to cope with that much nitrogen.

Comment to two of the people who posted on page one:
Excess NO3 is not a lack of or incomplete nitrogen cycle.
If there is no other source of NO3, then high NO3 is a sign that the cycle IS complete.
Seeing ammonia or nitrite (NO2) are signs that the nitrogen cycle is not complete.

In this specific case the OP said the tap water tested positive for NO3, and later posted about Osmocote in the substrate.
OP indicated quickly rising no3 levels, his tank is little over one month old. He had said nothing about the o+ before my post. O+ or not, I stand by my original estimation that his cycle is incomplete.
xmas_one is offline   Reply With Quote