The Planted Tank Forum - View Single Post - Need help getting my planted tank to thrive again
View Single Post
Old 02-10-2013, 05:06 AM   #1
gudgeon_42
Algae Grower
 
gudgeon_42's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2012
Location: australia
Posts: 26
Default Need help getting my planted tank to thrive again

A year ago i planted out my 5 gal tank with Ambulia, At first it had a hard time but then after a few weeks it set in and grew like a weed, my tank looked nice. I rescued a goldfish at some point and kept him in the tank temporarly untill i could find a pond for him to go in. A few months before i re homed him he ate all the plants after months of leaving them alone. I figured i would replant the tank once he was re homed. Anyway i found a home for him last week. Went to my local lfs and bought some Wisteria. It was in poor shape but i know it can recover easily. I cut off the healthy shoots and planted them. A week later all the regrowth is stunted and yellow. I'm trying to work out what deficiency is causing it. When i used to have Ambulia i occasionally would dose liquid ferts and that was it. I want to achieve the same thing again but obviously something is no longer right in my tank to achieve that. I also have one stalk of Ambulia in the tank with the wisteria and it is sick too. The tank is stocked with 3 Pepperd cory's i know that is too much but i started off with 2 and the third one is their offspring that i missed in my fry tank when i gave the fry away. They are really happy and always breed. Anyway can you guys help me to get my tank thick and green again.
gudgeon_42 is offline   Reply With Quote