The Planted Tank Forum - View Single Post - I need co2 help BIGTIME. Oh god what did I do wrong?
View Single Post
Old 01-26-2013, 05:03 AM   #38
HybridHerp
Planted Tank Guru
 
HybridHerp's Avatar
 
PTrader: (12/100%)
Join Date: May 2012
Location: New York
Posts: 3,730
Default

So, sort of update on my situation of sorts.....
I brought my regulator to this hydroponics shop in my area (very useful to know that's there) and the guy tested it for me and told me that the seals inside seemed to have gone bad, among other things.....

The way he told me it was is that the regulator was busted beyond worthwhile repair and that it had more issues going on than where even worth mention (or that I really could grasp the concept of). What is it that could have caused the seals to have gone bad on the inside though? Could the water/mineral oil that was getting past the check valves originally have done the regulator in......this was only happening for a day however, and this regulator was only hooked up to everything for a day, not sure how much damage could have been done in terms of that within my having started using this regulator...

However, for the time being I have a replacement regulator that is working so far so good (I have to tighten the connection on one of the needle valves though...still playing around with it but the regulator itself is fine and not leaking anything)

I'll still get pics up of the old regulator, but there isn't all that much to really see I guess. All I know is that, its busted, and I trust the guy from the hydroponics place (it just was leaking air everywhere, the regulator itself)
__________________
My 75 gallon High Tech Tank:http://tinyurl.com/n7zp47m
My 10 gallon High Tech Tank:http://tinyurl.com/qyf7s5o
My 5.5 gallon nano College Dorm Tank:http://tinyurl.com/p54uupj
Mom's Spec V:http://tinyurl.com/qjt3rw2
HybridHerp is offline   Reply With Quote