The Planted Tank Forum - View Single Post - I need co2 help BIGTIME. Oh god what did I do wrong?
View Single Post
Old 01-22-2013, 08:25 PM   #34
HybridHerp
Planted Tank Guru
 
HybridHerp's Avatar
 
PTrader: (11/100%)
Join Date: May 2012
Location: New York
Posts: 3,355
Default

Alright, sorry to take so long since I started this to get pics in here. I'll upload some by tonight for sure.

However, for now, I have the regulator off of the tank and sitting on a table to the side. I believe someone is going to give me a quick fix for this for the time being, since I go to school in less than a week, but I still have this regulator that I'm not sure about.

I'd love to see if I could find someone that I could bring this too and have them test things out and play around with it and whatnot, but in the meantime I'll try and get detailed pics and see what's going on with this.

However, I don't really want to put this back on my cylinder for the moment if I can help it, because last time I did the back of the regulator started having ice form and all that....also, if I do get something on my cylinder for now that works for me, I'm not going to take it off right away or anything.

I'll get pics up on here later tonight though, and I'll try and give any details that I can to the best of my ability.
__________________
My 75 gallon High Tech Tank:http://tinyurl.com/n7zp47m
My 10 gallon High Tech Tank:http://tinyurl.com/qyf7s5o
My 5.5 gallon nano College Dorm Tank:http://tinyurl.com/p54uupj
Mom's Spec V:http://tinyurl.com/qjt3rw2
HybridHerp is online now   Reply With Quote