The Planted Tank Forum - View Single Post - Pentax or nikon ?
View Single Post
Old 12-20-2012, 11:14 PM   #15
Snowflake311
Planted Tank Enthusiast
 
Snowflake311's Avatar
 
PTrader: (4/100%)
Join Date: Apr 2011
Location: SL Tahoe , ca
Posts: 948
Default

Quote:
Originally Posted by dmagerl View Post
Before you chuck that camera in the trash, try warming it up a bit.

First take the battery from camera, then warm your oven up to around 100 degrees F. If the thermostat will go that low, you're all set. Just put that guy in the oven and let it sit for a few hours. If the thermostat wont go that low, you'll have to monitor the temp closely and turn the oven on/off by hand.

Or if you have a gas forced air furnace, just put the camera on top of the furnace, after checking with your hand that it doesnt get all that hot. Let it sit there for a few days. Or even sit the camera directly in front of a heat vent, or on a radiator, anywhere warm but not that warm.

Once all the water has evaporated, it should start working.
It would be great if that worked. I will give it a try. I had it sitting in rice for 2 days. The weird thing is 24hr after I got it wet I turned it on and took 2 photos. Then left it out to dry more. Then tried it again and its stuck on one setting and the buttons do nothing.

So I think I turned it on too many times. maybe if I just left it off it would have been ok. Seems like from what I read about wet cameras you should not turn them on. oops I turned mine on and off a few times before it was dry.

I will try the heater thing.
__________________
20gal long planted tiger shrimp & RCS, 80gal planted discus community, 100gal SA cichlid delhezi, 7 gal betta, 20gal goldfish grow out.
Snowflake311 is offline   Reply With Quote