The Planted Tank Forum - View Single Post - API Algaefix...
Thread: API Algaefix...
View Single Post
Old 12-08-2012, 05:58 PM   #17
ADJAquariums
Wannabe Guru
 
ADJAquariums's Avatar
 
PTrader: (3/100%)
Join Date: Jul 2012
Location: Albany, New York
Posts: 1,430
Default

Quote:
Originally Posted by talontsiawd View Post
I just started using algae fix for the first time as I have this string algae that is seems to love the same conditions as the plants so it only struggles when my plants struggle. So far it isn't working well for this type of algae, but did get rid of the small amount I had on the glass and driftwood so I know it's doing something.

However, to my surprise, my plants didn't even flinch. I knew it was plant safe but I thought it would have some effect. They are just growing as they used to, still getting great growth and color, so not seeing any side effects there. Snails are dying but that's fine by me. Fish is not acting/looking any different.

Just saying, I had my concerns as well and now I am confident that this stuff is safe for plants and fish.
I was sort of sure it would be safe on my plants and fish but the thing i was most worried about is that it would kill my snails, it was a pain to find Trumpet snails in my area so i had to get them from someone on the forums. I would rather NOT kill those, glad to see i was smart by not adding any until i had some good info, thanks for trying it out
__________________

Then I saw it. I saw a mom who would die for her son. A man who would kill for his wife. A boy, angry and alone. Laid out in front of him, the bad path. I saw it. And the path was a circle. Round and round. So I changed it.
-Joe (Looper 2012)
ADJAquariums is offline   Reply With Quote