The Planted Tank Forum - View Single Post - Dwarf Sagittaria and swords melting after transplant
View Single Post
Old 12-05-2012, 06:48 AM   #1
blink
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Feb 2012
Location: Edmonton, Alberta
Posts: 564
Default Dwarf Sagittaria and swords melting after transplant

Recently I tore down my established 27 gallon and swapped everything into my new 25 gallon cube and now my dwarf sagittaria seems to be melting a little and my swords (not sure what species) are not doing well at all, the spiral val is also gross. The swords and val are going transparent and off color but on the sagittaria it seems limited to some of the leaf tips browning and breaking off and it just doesn't look as robust.

I suspect you are going to ask my nutrient levels but I don't have much for test kits, just the basics so I can't really test nutrient levels.
I've been dosing Seachem Comprehensive and Excel with a dash of Nitrogen when I first put the plants in and on water changes. I have root tabs in the substrate but it's brand new Fluorite.
There is plenty of flow and I hope to be getting my CO2 operational this week as long as I can find a needle valve.

I guess I'm just asking if it's normal for swords, spiral vals and dwarf sagittaria to melt a little before bouncing back or should I be yanking them out of my tank and starting over? I'm not too worried about the swords or val but I'd rather not toss out all my sag.
Also, about how long does it take for Seachem root tabs to start releasing fertilizer, or more importantly, how long until the nutrients can be used by the plants? I know that having new, un-pooped in substrate means it's pretty inert and I've read that some (most??) of the nutrients in the soil won't be usable by plants for a while, until "the bacteria break down the nutrients into a form the plants can use", is this true or is it an internet myth?

Hold my hand, tell me it's gonna be alright...
blink is offline   Reply With Quote