The Planted Tank Forum - View Single Post - Deficiency? Or pleco/snails?
View Single Post
Old 11-21-2012, 05:26 AM   #1
LyzzaRyzz
Planted Tank Obsessed
 
LyzzaRyzz's Avatar
 
PTrader: (16/100%)
Join Date: Nov 2012
Location: Rhode Island
Posts: 465
Default Deficiency? Or pleco/snails?

In my 50 gallon, my sword plants seem to have a deficiency..
Attachment 57530Attachment 57531Attachment 57532
The first two are my large sword plant the third is my small sword plant.
They seem to be getting thinner and thinner, and whiter, eventually getting holes. My large sword have a cramped gimpy leave, which leads me to believe its a deficiency.
But it could also be my plecos, i have a RN and a BN, or my apple snails, of which there are four in the tank.
I dose a capful of Flourish Comprehensive Supplement after water changes, and i dont have any substrate ferts as of yet, they are in the mail.
Is this a nutrient deficiency, or are my suckers going crazy on my plants?
I have two 36 inch t8 6500K light that are staggered on the top of my 48 inch tank, each on for four hours, while the other is switched off. Im having an algea problem, [starting another thread on that as well]


Also, my ten gallon seems to be having a deficiency as well:
Attachment 57533Attachment 57534Attachment 57535
The first picture is my aponogeton, it gets holes in its leaves, the holes seem to crumble?
The other two are some of my melon plant leaves, which are getting brown spots on them.
I also dose Flourish Comprehensive Supplement, about an 18 of a capful, the lights are two 14 watt CFL bulbs, on for about 11 hours a day.


EDIT: Sorry about the huge pictures, i thought TPT resized automatically?
__________________
50g, 45g, 15g, 10g, 2x2.5g, 2g bowl

LyzzaRyzz's Tanks and More! - http://www.plantedtank.net/forums/sh...d.php?t=226122

Last edited by LyzzaRyzz; 12-06-2012 at 08:06 AM..
LyzzaRyzz is offline   Reply With Quote