The Planted Tank Forum - View Single Post - BBA/CO2/lighting
View Single Post
Old 08-28-2012, 03:47 PM   #3
Seattle_Aquarist
Planted Tank Guru
 
Seattle_Aquarist's Avatar
 
PTrader: (37/100%)
Join Date: Jun 2008
Location: Seattle, WA
Posts: 2,540
Default

Hi mcaquatic,

I had that happen a couple of months ago on a 20 gallon newer set-up as well. What i did was:

Day 1
1) Check CO2 and adjust if necessary
2) 50% water change
3) Dosed Excel at the recommended initial dose (5ml / 10 gallons)
4) Fertilize normally
5) Normal Photoperiod

Next six days
1) Dosed Excel at 2X the recommended 'Daily' dose (2X 5ml / 50 gallons)
2) Fertilize normally
3) Normal Photoperiod

Day 8
1) 50% water change
2) purchased a Siamese Algae Eater (SAE / Crossocheilus oblongus) to eat the dead/weakened BBA tufts

Repeat as needed except 1 SAE per 20 gal should be enough.

My experience has been that BBA can be killed or weakened by Excel (glutaraldehyde) but unless I add an SAE to clean up the dead / weakened tufts of BBA it comes back quickly. My SAE's seem to be able to keep the young BBA from appearing but are unable or unwilling to go after mature, healthy tufts of BBA.

Today, no sign of BBA in the tank.
__________________
Roy
45 Gallon Tall; 96 Watt AH Supply CF; 6700K; & 30 Gallon Long; 2X36 Watt AH Supply CF; Press. CO2; UGF; Heat Treated Montmorillonite Clay
Greater Seattle Aquarium Society (GSAS)


Last edited by Seattle_Aquarist; 08-28-2012 at 03:49 PM.. Reason: add'l info
Seattle_Aquarist is offline   Reply With Quote