The Planted Tank Forum - View Single Post - 60P Iwagumi - First Try
View Single Post
Old 05-19-2012, 03:49 AM   #22
TexasCichlid
Surrounded by Blyxa
 
TexasCichlid's Avatar
 
PTrader: (27/100%)
Join Date: Jul 2011
Location: Texas
Posts: 1,506
Default

Well...bad news today. Broke my eBay intake lily pipe in half trying to get a screen on it. Barely any force. Ugh. Jury rigged the suction cups for my inline CO2 diffuser to hold the intake pipe down while I try and find another 17mm intake somewhere...

I planted some Blyxa from Tom Barr. I severely overestimated the amount of Blyxa I would need, or severely underestimated the amount/size Tom would send. Most of it went to waste. I was going to RAOK it, but I had the plants out while the glass shattered so I left them out too long. Pardon the low water level and the dirty tank pictures, cleaning up anything aside from glass was not high on my list this afternoon.

General Updates

Mowed the lawn -- Butchered the HC last weekend. Trimmed back all the old growth pretty much. Got a little algae development. Adjusting CO2 and with the new LED and cleaning crew, I am hopeful it's under control.

New fauna! - Turtle Nerite, never had one, very cool. A few Batiki and Tri-color nerites, and 3 amano shrimp.

New light! - Went LED. Bought a Finnex 24" Ray II DD LED setup. I am hugely impressed. Plants are pearling like crazy, and the thing is so low profile and attractive. The shimmer in the water is beautiful. I will never go back to normal lighting.

Disaster strikes...





TexasCichlid is offline   Reply With Quote