The Planted Tank Forum - View Single Post - Is my car going to die
View Single Post
Old 01-31-2011, 07:03 AM   #4
Noahma
Planted Tank Guru
 
Noahma's Avatar
 
PTrader: (8/100%)
Join Date: Oct 2009
Location: Northglenn, Colorado
Posts: 4,065
Default

Quote:
Originally Posted by Eden Marel View Post
I just thought I would ask, I have a 2003 Subaru Legacy Wagon Special Edition that has a problem.

I just don't want to schedule any trips to areas unfamiliar to my mom, because my mom is so unbelievably directionally challenged and no one will be able to rescue me if the car does die!!


This problem is, that when I drive anything faster than 35 MPH, the front of my car starts making a loud humming/thumping woom woom woom sound AND it gets painfully louder as I drive faster, or accelerate and slight turn at the same time. Hard to describe the sound.... like a somewhat weird sounding helicopter... a propeller type sound I suppose. The sound is the same, but it gets faster and louder the faster I drive.

And yes... unfortunately, I was late on my last maintenance in November and we went to Oil Can Henry's and they said I was driving without Oil. And then they said they would fill up my coolant, but they never did. Then my mom remembered, and we looked ourselves and apparently I also had no Coolant, so we filled the Coolant ourselves.


I'm not sure if this is an engine problem or what, so that way I can send the Appointment Form on the Dealer's site for an Engine problem or something else problem.



Oh yea, this problem started to happen before my lateness to my maintainence, I thought after the oil change and stuff that the noise level went down a notch but it could have been just me. But now the noise seems to have gotten a lot worst, much louder!! Also we got the Tires Rotated sometime in December. I got all four brakes and some belt changed in late 2009 or beginning 2010. My mom said they already changed the tires on this car few years ago. This car hasn't been washed for a year or so. I can't think of anything else.
Sounds to me to be a front end problem. Maybe a warped rotor etc. for the form, I would just state what you stated here, that it makes a whoping sound when increasing speed, that way they check the whole system
Noahma is offline   Reply With Quote