The Planted Tank Forum

The Planted Tank Forum (http://www.plantedtank.net/forums/index.php)
-   Algae (http://www.plantedtank.net/forums/forumdisplay.php?f=23)
-   -   SafeTSorb and diatoms??? (http://www.plantedtank.net/forums/showthread.php?t=443129)

BriDroid 09-25-2013 09:21 PM

SafeTSorb and diatoms???
 
I have SafeTSorb in my tank and ever since day 1, I've had an issue with diatoms. Reading that diatoms LOVE silicates,, I thought I'll just wait it out. A couple of months later, and still have tons of diatoms.

Reading around the web, I found that some say clay soils leach silicates! Oh no, I have a clay based soil! I did a little more digging, and decided to try Seachem Phosguard. I picked some up today with a LFS I had credit with. It's in my filter now. Hopefully this will help absorb the extra silicates! Hopefully it will be enough and I won't be fighting an uphill battle.

If this doesn't help, I think I'm going to dump the SafeTSorb and try something else. After all, it's only $5 worth.

Has anyone else had these issues with SafeTSorb?

steven p 09-25-2013 11:26 PM

I'm using it in a few tanks, I'm not having any abnormal algae. If it is just the glass, grab a felt magnet.

acitydweller 09-26-2013 01:29 AM

diatoms are typical of newly setup tanks. I've had this in all of my S-T-S tanks. a quick remedy i've used is a powerhead with a filter attachment. Another more direct method was to use an aquarium vacuum attached to an airline running along the surface to siphon debris and diatoms. A third and last resort would be to do the one-two punch using hydrogen peroxide then excel...

Black Pearl 09-26-2013 04:11 AM

Have had diatoms/ brown algae problems for months until I added a stronger filter. No more problems now.
Diatoms don't really stick to plants, glass or decor. They just "sit" wherever they form or fall. If filter is strong enough and water circulation is sufficient, diatoms are sucked in the filter and "cleaned off".
I believe if I turn off the filter that I added, Diatoms will reappear in my aquarium. They do not have the chance to do so now as the filter cleans them off faster than they can form.

Mizuhuman 09-26-2013 08:56 PM

I have safeTsorb in my 29g, but I don't have a big diatom problem. Its been running for 5 months now and I only see some diatoms like some spots or patches here and there, so I don't think its the safeTsorb.

BriDroid 09-26-2013 09:14 PM

Thanks for all the replys. I really didn't think it was the STS, but wanted to make sure. I'm running the Phosguard for a week just to see if it can get the silicates down. I'm sure the diatoms will take care of themselves eventually. I'm just frustrated, I have otos and nerites in there, but they won't eat them. Ramshorns are the only ones eating them.


All times are GMT. The time now is 01:43 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.