The Planted Tank Forum

The Planted Tank Forum (http://www.plantedtank.net/forums/index.php)
-   Plants (http://www.plantedtank.net/forums/forumdisplay.php?f=33)
-   -   Is my Egeria densa dying? (http://www.plantedtank.net/forums/showthread.php?t=433025)

ConcaveLiNkiN 09-12-2013 05:00 PM

4 Attachment(s)
Dear seniors and experts,

Are you able to tell if my densas are dying?

Attachment 207305
Attachment 207313
Attachment 207321
Attachment 207329

Thank you so much in advance.


Cheers
eRic

Sent from my iPad using Tapatalk

It seems like the leaves are turning transparent. But the stems look really green. Is that normal?


Cheers
eRic

Sent from my iPad using Tapatalk

micheljq 09-12-2013 05:57 PM

Looks healthy to me. Leaves can be somewhat transparent on Egeria densa.

Michel.

Rony11 09-12-2013 07:32 PM

Many reasons such as :Newly planted, Used excel in tank, medicated the tank,changed yr ferts, changed ferts dosage, a changed in tap water or used RO, bright light/changed yr lights, etc.. Egeria Densa is sensitive to changeds in an aquarium and it reacts by melting.

ConcaveLiNkiN 09-13-2013 02:15 AM

Quote:

Originally Posted by Rony11 (Post 4273865)
Many reasons such as :Newly planted, Used excel in tank, medicated the tank,changed yr ferts, changed ferts dosage, a changed in tap water or used RO, bright light/changed yr lights, etc.. Egeria Densa is sensitive to changeds in an aquarium and it reacts by melting.

I see. Mine's a newly planted tank:
Lights: 2sets of 2x24W
Liquid fert: ADA Brighty K
Substrate: ADA Amazonia
CO2: 2bps
Lights duration: 8hrs in the evening and 3hrs morning

The stem looks really healthy and green though and I could see new shoots coming out from the stem. Therefore, I presume that the slight melting on the leaves are normal, showing a sight to actually get use to the environment?

Thanks everyone for the feedback. :)


Cheers
eRic

Sent from my iPad using Tapatalk

shambhalove. 09-13-2013 11:37 PM

The plants leaves are only 2 cells thick :red_mouth

JMN16150 09-13-2013 11:40 PM

Eugeria densa also doesn't really like warm water unlike tropical plants

ConcaveLiNkiN 09-14-2013 07:07 AM

Quote:

Originally Posted by shambhalove. (Post 4282249)
The plants leaves are only 2 cells thick :red_mouth

2 cells thick? I tried googling on the plant, not very helpful though. Never really mention the problems people come into when caring for them. So I suppose this could be normal?


Cheers
eRic

Sent from my iPad using Tapatalk

Quote:

Originally Posted by JMN16150 (Post 4282265)
Eugeria densa also doesn't really like warm water unlike tropical plants

Ah... Warm water. The temp of my water is normally 29C to 27C. I am using quadfans and do not have a chiller.


Cheers
eRic

Sent from my iPad using Tapatalk

ConcaveLiNkiN 09-27-2013 09:32 AM

An update on my Egeria densa. After weeks, it seems to be growing pretty okay with no signs of dying. Yesterday I did a quick relocation, I moved all my densa to a spot under my driftwood:
http://img542.imageshack.us/img542/42/4k5x.jpg

after a couple of minutes, guess what happened:

Yes! It started to pearl! Nice, I believe the new location provided my densa with sufficient lighting, thus causing more photosynthesis and in turn it started to pearl.


All times are GMT. The time now is 04:13 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.