The Planted Tank Forum

The Planted Tank Forum (http://www.plantedtank.net/forums/index.php)
-   Plants (http://www.plantedtank.net/forums/forumdisplay.php?f=33)
-   -   Sword plant deficiency ID (http://www.plantedtank.net/forums/showthread.php?t=323090)

jkaber 05-03-2013 12:09 AM

Sword plant deficiency ID
 
1 Attachment(s)
My swords looked great....now not so much. I use fluorite, flourish tabs, all seachem/aqua vitro supplements, Guissman T-5s, pressurized CO2. Now my leaves are looking like this and trim them off everyday. My swords flower and send out countless runners every week. What deficiency is this? Attachment 136994

mc1973 05-03-2013 07:50 AM

One thing to consider is that if you are not cutting off the runners/flowers, the mother plants takes a pretty big hit. Something I experienced with my rose swords.

I'll follow to see if anybody else has suggestions.

roadmaster 05-03-2013 12:38 PM

Look's more to me like rasping damage from possible Pleco ?
Maybe pottasium (K2SO4) could be increased, and see what result's are after a week or two.
Am only guessing on the pottasium, due to it being utilized by plant's fairly quickly according to plant guru's.
I might be tempted to increase all macro-micro nutreint's a little and note any changes after a week or two.

jkaber 05-03-2013 03:47 PM

Sword plant deficiency ID
 
Yep, plecostomus. Caught them in the act last night! I guess I need to start feeding them. Plus I have about a dozen baby plecos now.


All times are GMT. The time now is 09:53 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.