The Planted Tank Forum

The Planted Tank Forum (http://www.plantedtank.net/forums/index.php)
-   Algae (http://www.plantedtank.net/forums/forumdisplay.php?f=23)
-   -   Brown killer algea! HELP (http://www.plantedtank.net/forums/showthread.php?t=278482)

ccbeauch 03-18-2013 01:22 AM

Brown killer algea! HELP
 
3 Attachment(s)
So I have kinad been letting this problem go on for a while now and it has really gotten out of control. I hit a last straw when I got back from a 10 day trip and my Fox Tail was dead and the other plants have one foot in the grave and another on a banana peal. I don't know what to do about it and its been going on for about a couple of months. None of my fish have been affected and thats kinda why I let it get out of hand I guess. Any suggestions on how to get rid of this dark dirty brown hairy algea would be great!

Light:
4x42"T12, 8 hours a day
dosing:
Just started excel this week, prior to that nothing, no CO2.
Fish:
6 discus, 6 cardinals, 2 Bristile nose plecos
Bristlenose plecos and random small snails don't eat it ( and i think one of those two might be eating my swords!)
Tank: 72 gallon bow front, 85F
Substrate:
50lb organic potting soil, 50lb eco complete, 75lb black sand.
Filtration:
110 Aqua clear and 75 gallon sponge filter

thanks for all of your help!

latchdan 03-18-2013 02:33 AM

Its black beard algae, remove most by hand/toss bad stuff. Spot treat with excel/Hydrogen peroxide. Increase Co2 if possible/ add DIY. Or you can try this method but make sure to read entire page fish death/invert death may happen.

http://www.plantedtank.net/forums/sh...ighlight=punch

ccbeauch 03-18-2013 02:45 AM

Thanks for a reply. I was really lost to what type this was and how to deal with it.

DarkCobra 03-19-2013 04:08 PM

Hehe. I actually referred Ccbeauch to start this thread from the "One-Two Punch" thread.

These were the pictures from Cc's tank journal that made me do it. From November:

http://www.plantedtank.net/forums/at...3&d=1352563200

To today:

http://www.plantedtank.net/forums/at...2&d=1363572018

It's the general decline in plant health that concerned me more than the algae. It looks like Cc has used CO2/Excel at some time in the past, and at some point discontinued it; I'm not sure of the timing and perhaps that's the only thing responsible. But as I have no experience with dirted tanks, I wanted to make sure someone who knows their dirt can take a look, and uncover any other potential issues.

UDGags 03-19-2013 04:16 PM

Re: Brown killer algea! HELP
 
I agree...needs more co2. Ramp up slowly!

Sent from my DROID BIONIC using Tapatalk 2

ccbeauch 03-20-2013 11:40 AM

I guess I did use a little CO2 and excel the first three to four months of operation and then stopped. Maybe that was why they look so much smaller now. I thought it was also because either the snails or my plecos were eating the sword plants and that's why they arn't as big anymore. I also figured the algae killed off the other plants and that was why they weren't growing either. I'm going to do the H2O2 later today and see if that works. Is that like an instant algae kill or like it's dead and now it will float around until the filter picks it up for a few days type thing?


All times are GMT. The time now is 06:20 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.