The Planted Tank Forum

The Planted Tank Forum (
-   Low Tech Forum (
-   -   One month post cycling with my low tech tank (

fishrule 02-09-2013 03:02 AM

One month post cycling with my low tech tank

This is my 75 gallon lowtech planted tank setup. Incidentally this my first planted tank, I usually keep cichlids or pico reef aquariums. Frankly plants are of little interest to me, but fish behavior seems so much more natural for many species in a planted aquarium. Plant growth has been fairly irregular but seems to be finally picking up after a massive initial melting period.

My setup consists of:

One Marineland 36 inch Doublebright LED at the front
Finne RAY II Daylight 48 inch at the rear
Aquaclear 110 with 2 sponges
1 inch Super Premium Dirt From My Backyard™
Some old inert substrate I had from a goldfish tank

Radican Swordplant
Giant Swords
Unidentified Eel grass I picked up at a pond
Salvinia molesta
Water lettuce

10 Blackskirt Tetras
3 Angelfish
4 Discus
Some random livebearers that I used as guinea pigs (some guppies, swordfish, platies)
1 male betta and a harem of three females

No dosing or other tech to speak of. Tank receives about 1 hour of daylight every day from the window. Fish seem very happy and I have had no deaths in the first month since adding fish post cycling. When I first setup the tank it took about 6 weeks for the soil to settle in. I was pretty surprised at my initial melting of plants, and I was sure the radicans sword was not going to make it, but it seems to be finally recovering.

All times are GMT. The time now is 12:09 PM.

Powered by vBulletin®
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.