The Planted Tank Forum

The Planted Tank Forum (http://www.plantedtank.net/forums/index.php)
-   Equipment (http://www.plantedtank.net/forums/forumdisplay.php?f=9)
-   -   CO2 Solenoid sticking open!!! (http://www.plantedtank.net/forums/showthread.php?t=110664)

newday3000 06-21-2010 07:34 PM

CO2 Solenoid sticking open!!!
 
I have been having problems with my new solenoid, controlled by ph controller, it's a clippard solenoid.

it sticks open and toggling power on and off doesn't get it to recover. I have taken it apart and cleaned with rubbing alcholol which seems to get it working again but it then seems to stick open again a couple weeks later

it's a spring loaded mechanism when solenoid is off, to push a rod upwards and reseal and block the flow of CO2.

Any one have suggestions. I'm guessing debris is in the solenoid is the problem. anyone else with this problem. Are other solenoids a better design to solve this. It's really PITA.

any permanent fixes for this.

Lycosa 06-21-2010 07:48 PM

Is it the rod getting stuck? If so, might add a drop of oil around the rod. I don't have a Clippard brand valve, but I've worked on plenty of solenoid valves in the past at work. There isn't much to them. As long as the coil isn't burned out, the spring tension isn't worn, and there is no interference for the pushrod to close the valve, then all should be fine. If the rod is starting to wear/damaged and it's dragging + the spring is worn out a bit from use, you could have that problem. If the spring is accessible, see if you can grab a similar tension/sized spring at the hardware store and replace. If the rod is sticking, lubricate it a little and work it by hand a bit until it frees up. If the rod is scratched/rough bad, then you might need to sand it with a Dremel to smooth out the rough surface, which 'may' be possible since it's CO2 and pretty rough on metals in the long term.

newday3000 06-21-2010 08:03 PM

the solenoid is new as of Feb. it shouldn't be worn out. I will try some oil on the sides. the spring seems fine to me. I guess if it's not aligned right it could stick on the way back up. The rubber seal at the head of the piston could rub and stick. I will try that and see if it helps.

I also find that when I turn on the power, I don't always get the clicking sound I was used to hearing which is the piston being pulled down by the magnet.

I will try a few things tonight and see how it goes.

zeldar 06-21-2010 09:41 PM

I had the same problems with my Clippard solenoid. Mine is a little over a year old though (got it online), but I've only had it a month.

I was told to open it all up with the powercord unplugged. Then turn the psi up to 30 and plug the solenoid in with the needle valve all the way open. This should push out all sorts of debris. While the co2 is flowing out plug and unplug the solenoid several times. This helps push more debris out. After about 30seconds of this turn the solenoid off and spray EVERYTHING with compressed air. THen put it all back together and cross your fingers.

This didn't work the first time for me but the second time I tried it has seemed to hold up (like 3 weeks ago). Hopefully you can get yours working. Please post your findings in this thread as I am not sure how long my fix is going to last.

newday3000 06-22-2010 12:31 AM

I took it apart and did the usual rubbing alcohol cleaning. I also turned off the main tank but left the regulator open, when I took it apart what ever gas is still in the regulator rushes out. I did this twice to flush out any debris.

I have also stretched the spring (carefully), to ensure it's fully extending when inside. I decided to use a queue tip with minute amount of olive oil to put around the top of the piston. not even enough to be visible afterwards.

I reassembled everything and did about 6 test start and stops by plugging in the solenoid. Everything was working well after this. I've been here before.... I can only assume I get more debris and the problem repeats or the solenoid spring is catching and not fully extending back up to block CO2.

I have my output side pressure set to about 12 psi, my thinking is higher pressure output makes it harder for the spring to shut off the flow. Not sure if this is a correct assumption but it makes sense.

I will montior tomorrow and see how it performs. My ph controller often toggles power on and off near the end of the day when my PH get's dialed in at 6.1.

Lycosa 06-22-2010 12:42 AM

Good luck, hope it works...keep us posted.

plantbrain 06-22-2010 12:54 AM

I've roasted 3 clippards. One recently was stuck and would open after 1-2 hours, so the 1st part of the lighting cycle, no CO2..........

I used a Reactor below and rarely look at it, so I did not realize there was an issue, the tank had some signs of poor CO2, all my other tanks where done the same light(same PAR, same sediment types, similar stocking levels of fish, plant density, same ferts added, same water changes etc).

I modified current for a bit to see. That did not help much.
Tried several slow modifications of bubble rates and watched etc.

I leave in the morning before the cO2 comes on for this tank so when I checked later in the day for issues, I was fooled. :mad::icon_evil
I caught it a couple of weeks ago. Took the valve apart, it was sticking pretty bad. I replaced it, the tank is doing much better already.

There's the rod, the chamber and the electrical part, any of these 3 things can fail. Without a data logging CO2 measurement, it can be very tough to tell what is going on. Gave me a world of grief.

But, I knew I could rule out some things and isolate it. This made looking in the right spot much easier, I also know what poor CO2 looks like, but it got me there, since the sucker was open and running fine when I'd get home.

If CO2 can get me, it can get anybody. There's a lot more to CO2 "than adding it", "or adding more". It's nailed me, it's nail Amano(ask him), anyone that's done this hobby long enough. Reef folks using Kalks and CO2 also have some serious words about solenoids.

I guess a multiple redundant system will prevent adding too much, but not adding enough or a sticking valve that does not open when it show, would require a more complex system.

So I got nailed.



Regards,
Tom Barr

newday3000 06-22-2010 01:08 AM

I would pay more for a solenoid that reversed the magnet to pull the piston up and down and not rely on a spring loaded piston. Not sure if this exists but if all solenoids are built using a spring they will suffer from this problem at some point. The electronics are not very complex to turn on and off a magnet, to me the spring is the weak link in the design.

herns 06-25-2010 02:01 AM

I have new Clippard that I have been using for barely a month and it was leaking!

shane3fan 06-25-2010 02:16 AM

this may sound silly--but make sure you have the solenoid installed with the 'I' and 'O' oriented correctly ( in and out ) If the solenoid is backwards it wont seal.

DarkCobra 06-25-2010 10:44 AM

Quote:

Originally Posted by shane3fan (Post 1096617)
this may sound silly--but make sure you have the solenoid installed with the 'I' and 'O' oriented correctly ( in and out ) If the solenoid is backwards it wont seal.

+1. I didn't see an 'I' or 'O' on mine though, so I just tried it out, and found it leaked.

Then I found this picture in a build guide:

http://img266.imageshack.us/img266/8420/solenoidgl1.gif

And found it was backwards. I used the two holes in the metal solenoid body as the reference to which side was the input.

newday3000 06-25-2010 11:02 AM

When you say leaked, do you mean it's not closing and CO2 is passing through it when it should be off. (seen in a bubble counter as bubbles) OR it's leaking CO2 out of the solenoid?

My problem was failing to close when power was off and bubble counter was showing full BPS as if it was turned on.

my cleaning done earlier in this thread has solved the issue for now and solenoid is shutting off CO2 via PH controller with out any issues now. Need to monitor to see how long this latest cleaning lasts.

FYI I doubt my solenoid was installed backwards, since it came from GLA assembled.

Momotaro 06-25-2010 11:50 AM

To follow up on shane3fan: Improperly installed Clippard solenoids will "leak" CO2 via normal flow pattern.

The CO2 should flow in the same path as the word "CLIPPARD" on the label of the solenoid. If the label is removed, look inside the ports of the solenoid. The port with the large hole in the center is the INPUT port. The port with the small, offset hole is the OUTPUT port.

DarkCobra 06-25-2010 03:10 PM

Quote:

Originally Posted by newday3000 (Post 1096760)
When you say leaked, do you mean it's not closing and CO2 is passing through it when it should be off. (seen in a bubble counter as bubbles) OR it's leaking CO2 out of the solenoid?

If that's addressed to me, I meant passing CO2 when it should not have. I did not have the needle valve installed yet because I wanted make sure any debris was first flushed from the system. When on, the solenoid passed a blast of CO2. When off, it passed a small amount at 15 psi, which became rapidly greater as I increased pressure at the regulator.

If I'd had the needle valve installed before diagnosing the solenoid problem, I think I would have seen a similar bubble rate regardless of whether the solenoid was on or off. The leak was enough, and the flow restriction in a needle valve is so high, that it probably would have resulted in almost the same pressure at the needle valve input either way.

herns 06-25-2010 09:09 PM

Quote:

Originally Posted by shane3fan (Post 1096617)
this may sound silly--but make sure you have the solenoid installed with the 'I' and 'O' oriented correctly ( in and out ) If the solenoid is backwards it wont seal.

A photo on post #17 shows where the leak is coming from.

http://www.plantedtank.net/forums/eq...leaking-2.html

I've read a lot of solenoid problems lately. I hope those folks who are looking for solenoids, particularly Clippards, would have a chance to read these threads before buying.

Thread Title: "Just had TWO parker solenoid valves die on me in one day!"
Link below.

http://www.barrreport.com/showthread.php?t=7326


All times are GMT. The time now is 07:09 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.