The Planted Tank Forum - Reply to Topic
Thread: Strange mulloscs eating my algae......anyone have them? Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-11-2003 09:53 PM
Lucio Yeah they probably are snails.Out comes the snail rid then.
03-11-2003 05:00 PM
corvus Thats what I was thinking, most of my baby snails appear white at first, before they grow much
03-11-2003 01:29 PM
m.lemay Are you sure they're not snails ?
03-11-2003 04:16 AM
Lucio My tank has recently been hit by an outburst of tiny mulloscs, which can only be described as white and very very small. I think they feed on algae as they do not seem to harm the plants, and are slowly moving about, much like a snail. If anyone has ever had these creatures let me know if they cause any damage. Thanx

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome