The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Plants > Glosso Turning White?

Thread: Glosso Turning White? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-02-2008 04:57 PM
NyteBlade Using my awesomely bad photography skills, I managed to get a picture. It seems like only some of the growth is affected (presumably new growth). The Ludwigia Repens might be exhibiting the same type of thing but it's hard to tell. You can see some of the leaves seem quite a bit paler then others.

09-02-2008 03:05 PM
EdTheEdge Just a quick note about CO2. This my opinion only. I don't believe drop checkers are 100% accurate about the amount of CO2 in your tank. They are good INDICATORS but in no way are they 100% accurate. If your Glosso pearls then you have enough CO2.
09-02-2008 03:04 AM
NyteBlade
Quote:
Originally Posted by EdTheEdge View Post
And make sure you have enough CO2.....!!!!!!!!
The drop checker is a solid green so I think I have enough CO2 in the water. I'll pay closer attention to CO2 levels. My best guess is iron at this point though, so we'll see how it goes. If there's anything else I'm missing, comments would be appreciated!
09-01-2008 07:15 PM
EdTheEdge And make sure you have enough CO2.....!!!!!!!!
09-01-2008 07:04 PM
NyteBlade
Quote:
Originally Posted by EdTheEdge View Post
When this happens to my Glosso it usually means that it is time to change bulbs.

But it could be an iron deficiency too. I routinely over dose on the Flourish iron - a bit. And I also have Flourite as a substrate. So in your case try dosing iron. Another thing my Glosso really likes is phosphate. It responds rather quickly when I up the phosphates.
The fixture is nearly brand new. I'm pretty sure the light that came with it was new (it was a refurbished unit) but either way, I know one bulb is new . They're dual daylight 6700k/10000k Sunpaq bulbs. With over 4 wpg, hopefully light isn't my issue - maybe too much light.

It could also be phosphate. I've throttled down phosphate dosing too to keep levels hovering at 1 ppm, but I think phosphates may be one of those things that you can't do any damage with if you have too much (within reason).

I'll try upping the iron dosage as well as the phosphate, maybe a little bit of everything. There's no fish in the tank though so I might need to add some more fertilizer to compensate. There will be angels soon though. Mwahaha.
09-01-2008 03:02 PM
EdTheEdge When this happens to my Glosso it usually means that it is time to change bulbs.

But it could be an iron deficiency too. I routinely over dose on the Flourish iron - a bit. And I also have Flourite as a substrate. So in your case try dosing iron. Another thing my Glosso really likes is phosphate. It responds rather quickly when I up the phosphates.
09-01-2008 01:45 PM
NyteBlade
Glosso Turning White?

I'm having a bit of a problem in my tank. A few leaves on my glosso have literally turned white. They aren't really translucent, they appear to be white, or atleast very very pale. I can't tell if it's new growth, old growth. I suspect some type of deficiency but the glosso was grown emersed too so it could be adapting I guess.

I have 130 watts of PC over a 29 gallon. Pressurized CO2 - bubble checker shows a consistent green. I've been following EI to a tee except I've been a bit lax on traces and iron. Water is fairly hard - 8 GH/KH I believe last time I measured. I suspect it could be an iron deficiency but I'm not entirely sure. I'm going to up trace dosing a bit via CSM+B, and maybe start adding additional Iron in the form of Seachem Iron and see what happens. Any other suggestions or causes to this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 01:59 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012