The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment > Got my $80 Pressurized CO2 running!

Thread: Got my $80 Pressurized CO2 running! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-06-2003 02:18 AM
Buck ____ :shock: ___ Weird Science

I know the problem Sam... you have too many dang connections !

Here is my setup...
Bottle to the Regulator to the Needle Valve to the "Air" Tubing Into The Tank

Reactor - Filstar XP2
Bubble Counter - That's me! I watch the intake tube of my filter suck up the bubble... 1 every 3-4 seconds

All the CO2 ya need without the Science Project...yeh im lazy
03-06-2003 12:57 AM
Rex Grigg I got the brass seal from the fire extinguisher place that fills my tank. I'll bet if you ask at a welding shop they might carry them also.
03-05-2003 04:06 PM
GulfCoastAquarian I'm going to take my CO2 tank out and weigh it tonight. That's the only true way I'll know if I have a leak or not. Otherwise pressure is stable at 820psi right now and everything seems to be working fine. I took a big cup of water and submerged my entire needle valve to regulator union and didn't see any bubbles forming on the valve, regulator or the vinyl tubing. When I put the tank back, after weighing, I'm going to tighten the regulator to tank connection a bit more. That nylon washer probably sees some plastic creep after a while and probably needs occasional re-tightening until it settles.
03-05-2003 01:23 PM
corvus Rex, Thanks for the info. Do you know where I can get one of those permanent brass seals for the tank/regulator? All is working fine now, so I'll not mess with it for the time being, but whenever i have to change the tank, I'd like to have one of those, sounds like the ideal solution.
03-05-2003 12:22 PM
Rex Grigg corvus,

You must have had a tank with bad threads or a bad regulator. You don't want to use teflon tape on the regulator threads. If a piece of that stuff gets into your regulator you are screwed, and so is the regulator. All that should be needed on the regulator threads is..... nothing. The washer should seal that connection. And did you know there is a permanent brass seal for that connection? It screws into the regulator and has a O ring on it. Works like a champ! All the other connections on my tank use pipe dope. I don't like the idea of the way the teflon tape shreds. It can clog needle valves real easy.
03-05-2003 12:10 PM
corvus I'm embarrased to say I went through 3 TANKS! before I found my leaks.

Mine leaked at the tank/regulator connection, and at the needle valve.

soapy water, didn't work,

leak detector fluid, didn't work,

Finally, I submerged the entire system under water to find the leaks (the old bicycle tube approach, for use old timers out there). Had to do it quickly, as to avoid ruining the regulator (regulator gauges fill right up with water when submerged, I think they can be ruined easily this way). Then I used a combination of teflon tape at the regulator/tank, and massive globbs of silicone at the needle valve connections. Let it all dry for 3 days before hooking back up. It worked for me, been going almost 3 months with current tank, no drop in pressure except temperature fluctuations, as someone mentioned above.

As an aside, my house plants all ate up the co2 in the house during the leaks, you should have seen the new growth!
03-05-2003 02:12 AM
Rex Grigg Tank pressure will vary with the temp.
03-04-2003 09:23 PM
ridns I had to refill after a month ....., found I had a leak where the regulator is attached to the tank. Tighten as tight as you can , plus a half turn.
That sucker must be tight! Its amazing how much better it works without a leak! Good luck.
03-04-2003 09:08 PM
GulfCoastAquarian Well I've been doing quite a bit of reading in the past hour and I've found that silicone will generally lose 5%-10% and regular airline tubing (usually vinyl) loses 30%. I'm definitely going to upgrade to the CO2 tubing the next time I place an order, but can't justify the cost just now.

The regulator is sealed with a soft plastic washer that came with it. I tightened it pretty well but didn't use any teflon tape. I figured if the washer didn't do its job, the tape wouldn't be much use at that pressure.

What you said did make sense, though. But I don't think I'm going to worry about it. This might just be normal settling and temperature fluctuation. It has been at 820psi for about 24 hours now and it should stay that way until the cylinder is just about empty. For some reason I was under the impression that the tank pressure reading would slowly drop as the tank emptied. But since CO2 resides in the tank in liquid form, it won't start dropping in pressure until the liquid has all turned to gas. (just talking out loud if you know this already, hehe)

Right now, I have no reason to believe there are any leaks, I guess.
03-04-2003 08:54 PM
SNPiccolo5 Silicon tubing will lose CO2, more than CO2-resistant anyway. But if your pressure is dropping quicky, then wouldn't the leak have to be before the regulator, since the cylinder wouldn't release more CO2 if there was a leak after what is stopping it, if that makes sense. However, a leak would effect the amount of CO2 that is going into your tank....

How is your regulator attached to your cylinder? I know that it has to be very tight to work, and I used teflon tape as well at that connection.

-Tim
03-04-2003 07:51 PM
GulfCoastAquarian All the fittings on the regulator came tightened with teflon tape. No wonder that part doesn't lose pressure. But the outlet of the regulator is just a barbed fitting. I used a short length of clear vinyl tubing over the barbed fitting and tightened the mess out of it with a steel clamp. What is definitely questionable is where I simply slid the vinyl tubing over a threaded fitting that came with the needle valve and tightened that with a hose clamp. I did apply some silicone to the threads but I need to re-evaluate that fitting.
The rest of the tubing is silicone tubing, which I thought wouldn't leak CO2?
03-04-2003 06:29 PM
anonapersona Oh, wish I copied the original site of this post. It was so good I hardcopied it. It might have been from this forum, or another, I suspect here, though.

Anyhow, "Tim" found that he had a leak at the bubble counter, the needle valve, the check valve (replaced that with a metal CO3 check valve with barbs and a tightening hex nut), found he had to replace washers between the cylinder and regulator at each tank fill up, and then found that 30 % of his loss was the silicone tubing. Replaced that with CO2 proof tubing from marine-monsters.com. He mentioned the test kit, from welding shop or beverage supply house, said that soap works for large leaks, but appa ently he needed this stuff for small leaks. He said that 80% of his CO2 was escaping unused. And weigh the bottle to see the usage.

Just a "head's up", trying to help pass on what seemed to be good info.
03-04-2003 06:20 PM
mitche8359 Yeah the dishwashing soap and water solution will work. That's what I use to check for natural gas leaks. Good luck finding the leak.

Did you happen to use silicon tape at the fittings?
03-04-2003 06:02 PM
GulfCoastAquarian I might try some dishwashing liquid and water and try brushing it on each connection. This would really be a pain if I had to go refill the container just a few weeks after I got it, haha.
03-04-2003 05:32 PM
geekgirl Use kids' bubbles. Brush them on and wait to see if they bubble up. Cleans up easy too.

Stacey
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 07:14 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012