The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > DIY > Guide: Arduino based LED controller for Current Satellite LED+

Thread: Guide: Arduino based LED controller for Current Satellite LED+ Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-23-2015 07:02 PM
alpha1172 oph awesome i think i have a few megas sitting around. gonna have to try it out id need to order that button/lcd shield though
04-23-2015 06:44 PM
kman
Quote:
Originally Posted by alpha1172 View Post
U still using the sat +?
Me? I have both Sat+ and E-Series on my main tank.
04-23-2015 12:03 AM
alpha1172 U still using the sat +?
04-22-2015 08:57 PM
kman I never tried it. I have since moved over to the iAqua Lite for my smooth fading needs. (which borrowed Curt's crossfade code, IIRC)

Now I have to decide if I'm going to sell my two controllers off, or break them down to play with on other projects...
04-22-2015 07:17 PM
alpha1172 So i built one of these a bit ago, running version 3.6 works great!

I really wanted to try the version 1.0 by curt with the built in fading but it never controlled the light correctly. Did anyone ever get it to work correctly
04-22-2015 06:37 PM
kman
Quote:
Originally Posted by Dazzlin Dave™ View Post
Heres the link to the file : https://www.pjrc.com/teensy/td_libs_IRremote.html

Everything is looking/working good as far as your alarms kman. I will adjust/change them as needed. Thanks for all the assistance last night !

And once again, thanks to everyone involved in this project. Your work is awesome and very much appreciated by me !
There is so much good code and help around here...woot
No problem, thanks for the link! I added a pointer to it to help people with future issues. If I think about it, at some point, I'll zip up all the libraries I used, so working versions will all be collected in one place they can download right from here.
04-22-2015 07:54 AM
Dazzlin Dave™
Quote:
Originally Posted by kman View Post
Oh, wow, that's good to know.

What's the link to the updated file? I'll edit my post, if I can, and add the new one with the version that works.

Or, yeesh, maybe I should just package up all the libraries with the current, working versions and add that.
Heres the link to the file : https://www.pjrc.com/teensy/td_libs_IRremote.html

Everything is looking/working good as far as your alarms kman. I will adjust/change them as needed. Thanks for all the assistance last night !

And once again, thanks to everyone involved in this project. Your work is awesome and very much appreciated by me !
There is so much good code and help around here...woot
04-22-2015 04:50 AM
kman
Quote:
Originally Posted by Dazzlin Dave™ View Post
Finally got the compiling done ! The gethub link has an updated file, and was causing the issue.I found an older ver online that works.

Now to figure out why the lcd isnt showing characters. At least the light is working
Oh, wow, that's good to know.

What's the link to the updated file? I'll edit my post, if I can, and add the new one with the version that works.

Or, yeesh, maybe I should just package up all the libraries with the current, working versions and add that.
04-22-2015 04:45 AM
Dazzlin Dave™ Everything hooked up, lcd working, running tests now for the timers.
Fingers crossed !
04-22-2015 02:04 AM
Dazzlin Dave™ Finally got the compiling done ! The gethub link has an updated file, and was causing the issue.I found an older ver online that works.

Now to figure out why the lcd isnt showing characters. At least the light is working
04-21-2015 07:50 AM
kman One more thought:

I know we have addressed the library folder, but make sure that you are saving the sketch under the Arduino folder in your document section.
04-21-2015 06:43 AM
Dazzlin Dave™
Quote:
Originally Posted by kman View Post
Progress!

Can't hurt to try to download your IRremote library one more time, just in case. I don't know that it's the problem, but its a quick fix, if so. Be sure to exit and relaunch the Arduino software.
I'll give it another try...maybe 4th time is the charm...lol

I'm soldering the components up right now...boy, talk about rusty !
I have no idea what I will use for a case, so I'm putting 8in wires between the pcb and the rtc with 90deg headers on both..might make battery changes simpler.
04-21-2015 06:21 AM
kman Progress!

Can't hurt to try to download your IRremote library one more time, just in case. I don't know that it's the problem, but its a quick fix, if so. Be sure to exit and relaunch the Arduino software.
04-21-2015 05:54 AM
Dazzlin Dave™ Ok, have the resistor/led hooked to uno on pin 3 and grd..looking better

now, just have this error message:
This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.
Arduino: 1.0.6 (Windows 7), Board: "Arduino Uno"
test41.ino: In function 'void SendCode(int, byte)':
test41:276: error: 'class IRsend' has no member named 'sendNEC'
04-21-2015 05:26 AM
Dazzlin Dave™ Yes, my library location is same as yours
and yes, using this: "Current Satellite LED+ Controller V4.1 - MODIFIED FOR KMAN v2".

I am only using these librarys:
DS1307RTC
Iremote
LiquidCrystal
RTClib
Time
TimeAlarms
Dallas Temperature
OneWire
Do I need the others that you have showing?
/edit
are you saying that the ir led needs to be on the board atm?
/edit 2
I have nothing hooked to the uno right now..just my usb cable. I will feel pretty stupid if it has to be connedted to everyhing right now...
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 04:13 AM.


Powered by vBulletin®
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012