The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Plants > Help: Melting Limnophila aquatica (ambulia)

Thread: Help: Melting Limnophila aquatica (ambulia) Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-29-2013 06:09 PM
Jester946 Some plants will melt at first when moving from one aquarium to another. My Aromatica is BRIGHT purple and yellowish green, and it's VERY tightly grouped. I can tell you, that the plant loves a lot of potassium, and when I started to ramp my K up, it only got brighter, and grew faster/
07-29-2013 05:31 PM
tithra Just wanted to update, the limno fully bounced back. I lost several stems, but the remaining ones look great and are growing fast. Must have just needed some time to adjust


Sent from my iPhone using Tapatalk
07-22-2013 07:52 PM
tithra
Quote:
Originally Posted by Sgtreef View Post
Give it time then.

Maybe try some plant tabs.

Jeff
thanks I will given them some time and hope they adjust!

I threw some seachem root tabs under the AS when I setup the tank
07-21-2013 11:41 PM
Sgtreef Give it time then.

Maybe try some plant tabs.

Jeff
07-21-2013 01:29 PM
tithra Thank you for your reply Jeff. I did plant stems individually so they are spaced a bit apart, maybe not enough though? I will try spacing them farther.

This is a betta tank so flow is pretty low, but evenly spaced across the tank using a spray bar.




Sent from my iPhone using Tapatalk
07-21-2013 10:02 AM
Sgtreef Do you have space between the stems where light can get to the bottom of the stem?
High water flow?

Try Milfol maybe?

I have some and it is growing, most under some DIY LED's and really not a high flow of current on that side of the tank.

Wish you good luck as it is a real graceful plant.

Maybe give it awhile to adjust my PH 7.6 BTW.

Jeff
07-21-2013 03:51 AM
tithra
Help: Melting Limnophila aquatica (ambulia)

I have a newly setup (about a week old) 13.3 gallon tank.
*Lighting - 48watts t5ho
*Following EI dosing schedule
*co2 - 88g fluval kit (until I save up for something better)
*estimated co2 levels are 25 ppm (using ph/kh chart), drop checker is a happy green
*substrate - ADA aquasoil, about 2 inches deep
*no inhabitants currently (there is a betta that will call this tank home but she is in a different tank currently)
*zoo med 501 nano canister (cycled)
*pH 6.7, ammonia 0, nitrite 0, nitrate 5ppm

All plants are brand new, only about a week old. Everything seems to be adjusting ok so far except my limno. The bottom of the stems are completely melting away and bottom leaves are turning to grey mush.

I have had the same thing happen with this plant in a different tank and was unable to salvage it.

Tops still look nice and green, top half of stems still look good.

How do I save this plant before it completely melts away?? I read others say it grows easily and like a weed.... not sure what I am doing wrong. Any assistance is greatly appreciated

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 10:21 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012