The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment > Rena Filstar XP3 review - compared to Eheim

Thread: Rena Filstar XP3 review - compared to Eheim Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-20-2013 05:52 AM
justluv
hi

hello, i know im not the smartest person but i do love fish and i love to save as much money as i can so im for the xp3 i have one and it was a little loud at 1st then i notest it needed more water in it so you would not hear anything added anuff to over fill it put lead on got a little water on the floor no biggy because now i hear nothing from my filter got it used replaced the seals on it no leaking or sound and for the price it was well worth it on the off not i dont own the other filter but my friend that owns the pet store where i buy ever thing does on her 1st tank all her other tanks are XP3 filters cheaper and just as good
and on the off not that is something does mess up it well be cheaper to fix the XP3 as well
12-19-2011 04:44 PM
hbosman
Quote:
Originally Posted by fresh.salty View Post
I do the same thing but leave it running and burp it on the fly.
I used to do it this way but discovered that it filled faster when powered off.
12-19-2011 04:38 PM
fresh.salty I do the same thing but leave it running and burp it on the fly.
12-19-2011 04:34 PM
hbosman I've had an XP2 since 2006 and no problems so far. My next filter will be an XP3. I get rid of air by unplugging power cord and then unlatching one latch, then relatch as soon as the water reaches the top which happens very quickly.
12-19-2011 04:19 PM
gray_fox I have to chime in on this too.... I have 4 Rena Fillstar Canister filters. In my 125 gallon in the living room, i have 2 XP4's and 1 XP3. In my office i have one XP2. I never once ever ever ever had a problem with them. I let the one in my office go for months without changing it and the flow rate was always good, even when that sucker was FULL of crap! They are the quietest things i have ever used. I was given a brand new eheim and wasnt really impressed comparing it to the Rena. Its really easy to clean and maintain. Filling and priming is so easy too. I have had these in tanks with sand and had no issues either... Ive never had airlock issues, or any flow issues.
When it comes to taking them down and cleaning them, its sooo easy and you don't have to re-prime, IMHO. I wouldnt buy anything else. I have convinced several eheim owners to buy a rena xp3 and they were just very impressed with it....
12-18-2011 10:07 AM
SteveWax
You Hear Noises and things !!!

After reading all the posted comments here, There is 1 Major & Important Over sight.

When it comes to Rattling, Nosies, ETC, This is all to do with AIR LOCKS.
What has not been said is how to properly remove them.
This is the easy part. Do not rely soley on the Caniters to do the job. After all, when 2 pieces of plastic are joined together with water in the middle You are by the grace of god will have trapped air..

After setting up & Priming your Units, TURN OFF THE FILTER PUMP, Lower the OUT FLOW hose into a bucket at floor level, Switch the filter pump back on, this method allows the head of the Pump to syphon itself, Here you will be able to see the Bubbles (AIR LOCKS) in the hose.
When all the Air has gone, You will now have a quite System
Of all the Filter systems I have had over the past 30 Years, The above method always works on all Filters. Hope I have helped
01-15-2011 10:57 PM
tlawrenson I have an XP3 running my 55g and have had no problems except the first time I cleaned it I dropped the canister and broke it, so I went and bought a whole new XP3 and now have one spare part for everything, - the canister of coarse.

Suck it up buttercup, it makes like no noise wse!
05-22-2007 07:12 AM
2wheelsx2 Except that tab that keeps it from moving is rather flimsy. I managed to break it when I was cleaning it when I was taking the filter down. No big deal I guess, just have to be careful not to pull the lever when it's disconnected.
05-21-2007 10:16 PM
crazy loaches I actually edited my post already for exactly that - didnt realize back then that the valves couldnt be opened after disconnection. And I dont know why I have some kind of problem with typing level instead of lever. lol.
05-21-2007 09:08 PM
Naja002
Quote:
Originally Posted by crazy loaches View Post
Sometimes with the XP3 I worry that the disconnect lever operates to easily. For example when I am putting the filter back in place in the cabinent after a cleaning i worry the hose assembly might get caught behind it and the level pressed back so it starts dumping water, never happend yet but something I think about every time I do it. I should just come up with something I can hang the assembly on out of the way when manuevering the unit back in place.
If You look at the xP quick disconnect assembly--there are 2 little locking mechanisms to prevent exactly what You are talking about. The handle won't move unless its connected to the filter.....


HTH
05-21-2007 08:10 PM
crazy loaches Betowess - my newer XP3 I just got on the petsmart $75 deal does have a different configuration where the impeller shaft rests into the housing. My 2 yr old one has a solid plastic bushing of sorts - non removable if I remember, whereas the newer one has a removable rubber plug like piece. I cannot hear a difference between the two - I very mild hum with the occasional trickle of water noise (usually only after water changes). There is only 2 yrs between them though; perhaps there was more changes in earlier models yet. They work fine although I am playing with different media configurations to hopefully increase flow and duration between cleaning.

In a very quite night laying in bed I cannot hear my 2026 about 3 foot from my head, but I can still hear the faint hum of the XP3 on the other end of the house in the living room. To me the XP3s are quiet, not silent, but not disturbing. If the tank was going in a bedroom I'd defiantly recommend Eheim. In a family room, XP3s are great. Thats just my opinion, and what I did.
05-20-2007 06:02 PM
Betowess I don't recollect the exact part, but I recall reading that Rena put in a better rubber part on the impeller a few years back and the newer XPs are substantially more quiet as a result. My current XP3 that I am using, one of the later models, runs near as quiet as my Eheims.

That said, I'll stick with Eheims now. The plastic baskets are much better quality and seat in the canister much more easily.
05-20-2007 05:41 PM
cowfish i ran xp3s for 6 years 2 of them they just got louder as time past . now i have a ehim wet/dry 2229 and a catalina ultra 1000. i love them both they ar silent my xp3s were not silent when they were new. i really like my catalina it only cost me 56 bucks and its bigger than my ehim.
05-19-2007 02:33 PM
Blackthumbwoes I'm not sure what type of fish you're keeping with the XP3 since I've never owned or worked with them. So far i've only dealt with fluval (and i like them). But if you're filter is plugging that fast then i'm going to take a shot in the dark that maybe a more thorough hydrovacing might extend the times between cleanings. My canisters only plug up fast on bare bottom tanks (where everything goes into the filter) and tanks where i feed exceptionally heavily. With out meaning offense sounds like there is more in the tank that could be removed to spare the filter doing it. I just cleaned my 404 on my 100 gallon when the water flow was unacceptably slow. It was over two months since the last time i touched it and its now bare bottom so my lungfish poop plugged it up .

Anyhow i might try an XP3 i'll be needing another larger filter soon if i get my 120 set up properly. But i work in a LFS so i might just save my pennies and get a FX5 (damn those things pack a punch).

Anyhow this thread was really helpful i get a lot of people asking about pro's and con's about canister filters at work and i've been wondering myself. Thanks to everyone for posting their opinions .

Jason
05-19-2007 12:55 PM
Algenco Mine is totally silent also!!
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 03:33 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012