The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment > Help me complete this setup please....

Thread: Help me complete this setup please.... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-20-2013 03:27 PM
james0816 I don't rely on the count myself. I only inquired since I'm still waiting on some more drop checkers to arrive.

One thing I didn't plan on was check valves. DOH! Not something I had to worry about with DIY since the bottles were right next to the tanks. I went to turn on the gas this morning and all the tubes were full of water. Will be making a stop to Petsmart this evening to get some check valves.
05-20-2013 12:18 AM
Darkblade48 Bubble rate is not a good measure to determine anything. From bubble counter to bubble counter, the size of the bubbles will vary, and does not indicate how much CO2 is actually being dissolved into the water column.
05-19-2013 08:19 PM
james0816 tore apart that trouble BC and flipped the gaskets. Tightened everything up once again (maybe too tight) and now gas is flowing from all 6 manifold ports. Yay me!

Friends, I think I may be able to say I have finally....FINALLY...joined the ranks of the pressurized club.

Now of course I'm still in testing phase as I'll let it run til about 2000hrs today and see what we got after that.

I hooked up one drop checker to a tank and will adjust from there.

My count is around 1 bubble every two seconds at the moment.

With these bubble counters, a should be looking at around 1-2/second right?
05-19-2013 06:29 PM
james0816 so i got my original regulator back on friday. just now had time to test things out. once again i got everything hooked up and this time (so far...knock on simulated wood) it's all pretty much working with one exception. i'm still having issues with one particular bubble counter.

other than that, i have c02 currently going to five tanks. I'll leave it running for the most part of the day and see where we are at later this eve. If all is still well, i'll hook up the timer and be good.

I'll play around just a bit more with the trouble BC and see if I can't get it leak free.
05-07-2013 07:34 AM
vvDO Buy a 1/4" NPT brass plug, you can get this at Home Depot or other hardware stores. Plug your Low pressure output on the regulator, then follow Bettatail's leak test, linked here... http://www.plantedtank.net/forums/sh...d.php?t=137245. Then post your results.
05-07-2013 01:45 AM
james0816 alright...this is getting extremely frustrating.

I retaped everything, made sure all connections are tight. Sprayed soapy water over everything and didn't notice any bubbling anywhere.

I turned on the tank and set my pressure, turned on the solenoid and set the bubble count to about (2) BPS.

I went to the gym, come home and check things...the LP guage is 0 again!!! WTH!!!

I'm really open to more advice here guys and gals. Driving me absolutely nuts!

My reg should be back this week so it looks like the temp one won't even be useful.
05-04-2013 01:48 PM
james0816 Got the temp tank hooked up and set the pressure. Everything tested fine...or so I thought.

Set the operating pressure and counted bubbles. One bubble counter still not wanting to cooperate. So I changed it out.

It looked ok so I went to the gym. Came back and no bubbles and the LP was 0. Drat...there's obviously a leak somewhere.

I'll break it down again and retape everything.
05-02-2013 02:44 PM
james0816 I brought the reg into work and had our welder look at it. He replaced the PRV and got the same results. Said it needs to be rebuilt. Dang! I'll stop by a shop today and see what it's gonna run.

On a bright note, he did provide me with another Victor reg to use in the mean time. Sooooo kewl. Now I get to go through all the frustrations of hooking this up again.
05-02-2013 12:18 AM
Darkblade48
Quote:
Originally Posted by james0816 View Post
Well...my frustrations got the better of me and broke the system down.

Do you think it would be worth taking it to AirGas to look at? Not sure if they can test them there or not.

I don't want to keep buying pieces and parts.
You could take it to your local welding store to see if they can take a look (some might do an initial look for free).

The repair costs might be high though (i.e. more than the cost of buying another used regulator).
05-01-2013 11:54 PM
james0816 Well...my frustrations got the better of me and broke the system down.

Do you think it would be worth taking it to AirGas to look at? Not sure if they can test them there or not.

I don't want to keep buying pieces and parts.
05-01-2013 11:35 PM
oldpunk78
Quote:
Originally Posted by james0816 View Post
So I guess this reg is actually no good then eh??



So not happy right now
Not necessarily. Worst case, your 2-stage reg is running like a single stage. Best case, you just need a new relief valve or just a plug. If you fallowed Bettatail's leak check guide to a "T" and didn't find any problems, you just have a faulty relief valve which is replaceable.

This is just another one of those reasons I don't buy regs that look very used anymore. I mainly just look for ones that are new or almost new. I was throwing out 1/3 of the ones I was picking up cheap that had blown diaphragms or other issues.
05-01-2013 11:29 PM
james0816 So I guess this reg is actually no good then eh??



So not happy right now
05-01-2013 11:19 PM
oldpunk78 The relief valve leaking is a sign of too much interstage pressure (meaning the first stage is blown) or a bad relief valve.
05-01-2013 11:11 PM
james0816 So do I need to increase the pressure then? Sry as I'm confused since the relief valve is gassing off. Thought that was a sign of too much pressure
05-01-2013 10:53 PM
oldpunk78 Get a 1/4 plug and replace the relief valve with it. Turn your working pressure up to 20 or so to get you're needle valves more consistent. Maybe higher. The most aquariums you are feeding gas to, the more pressure will have to increase.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 08:01 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012