The Planted Tank Forum - Reply to Topic
Thread: Fluval FX-5 Help Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-23-2013 07:59 AM
Delexboarfoot That connector MUST be INSIDE the tank. NOT outside!!!!!!

You should have 2 black plastic formers that are designed to guide the pipes over the side of the tank. The connectors go INSIDE the tank after the guides.
04-22-2013 08:28 PM
stevenjohn21 Ok thanks, i had to make sure just incase. I would hate to come home with 125 gallons on my floor.
04-22-2013 06:57 PM
WheeledGoat Yep - same deal on my 206. Though I must admit my jealousy that your rubber connector is black. Mine is white. (I just bought some Krylon Fusion spray paint to remedy that.)

No leaks for me. And frankly, that connector is the best way to ensure no leaks. I won't even trust a worm clamp on that ribbed hosing.
04-22-2013 06:47 PM
tiggity That is how it connects. I've had my fluval 306 for a year now and no leaks. Also that junction goes through the hanger clip and in the water to provide a seal.
04-22-2013 06:41 PM
Fluval FX-5 Help

I just bought i used FX-5 and although its only 2 months old, it did not come with an instruction booklet so i have no idea if this is correct or not.

The pictures below are of the rubber connector that i presume connects the hose to the inlet/outlet ? Considering how much water this filter pushes, it does not seem very safe ! I have tried it out in a bucket first to see if any leaks started but couldnt find any. It just scares me that im relying on 125 gallons of water to be kept in the tank and not all over my floor, by this flimsy connector which doesnt take a lot of effort to pull clean off.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome